WordPress.org

Ready to get started?Download WordPress

Forums

Minify breaks my blog's layout and I have no clue how to fix it (54 posts)

  1. alexwrld
    Member
    Posted 1 year ago #

    Dear developers!
    I recently installed W3 Total Cache and also tried hands on WP minify. Both pluggins give my website the shape of a garbage. Needless to say, the css and js are the real culprits :-(

    Could any of you spare some minutes and have a look into the blog and give me any clue? I'll be grateful to your help and support.
    Best,
    Alex
    Blog: http://www.successstories.co.in/

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Start by validating your pages for errors -- both HTML and CSS:

    http://codex.wordpress.org/Validating_a_Website

  3. alexwrld
    Member
    Posted 1 year ago #

    Validation is done Yogi but no success at all :-(
    The entire W3 Total Cache seems to be useless. The site is still very slow.

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

  5. alexwrld
    Member
    Posted 1 year ago #

    Hi Andrew!
    Earlier, there were 263 warnings and 189 errors. The validation issue has been resolved..a couple of errors aren't related to Minify or Speed (I guess)

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    No, those are still problematic errors.

    Have you used any of the page-speed check sites to see what else is going on? The page is definitely slow -- I gave up on it. But you do have a ton of stuff on the page -- so it's going to take time to load all that.

  7. alexwrld
    Member
    Posted 1 year ago #

    Thanks Yogi!

    We have checked our website on Google Speed Check, GtMetrics and Pingdom. These tools are indicating on working on Browser Cache. We have already installed W3 total cache plugin. But the problem is the two sections aren't working: Browser Cache and Minify.

  8. alexwrld
    Member
    Posted 1 year ago #

    And by the way Yogi,
    If you tried opening the website in the past hour, it is opening slow because according to Google Analytics, there are at least 30 active visitors on the website (peak time)

    And this is the real problem.

  9. cinghaman
    Member
    Posted 1 year ago #

    Alex your site opens within a decent time amount for me except for the images loading too slow, testing further i saw that you use timthumb which is the culprit (takes around 30 to 40sec)
    http://tools.pingdom.com/fpt/#!/oHO0LJ5un/http://www.successstories.co.in/

  10. alexwrld
    Member
    Posted 1 year ago #

    Hi Cinghaman!

    If the timthumb are the real pain, then what are the options do we have?

  11. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    If that's the real problem, perhaps you need better hosting? I just left it loading for at least ten minutes and it never finished, so you likely have some other problems. Fixing the code errors is a good start.

  12. alexwrld
    Member
    Posted 1 year ago #

    Yogi,

    I have taken BlueHost's premium hosting account. I had a word with them and they seem to put the blame on us (the theme)

  13. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    What theme is that? I never got the site to load so it would not View Source either. Given the timthumb problem mentioned above, maybe you should find another theme.

  14. cinghaman
    Member
    Posted 1 year ago #

    timthumb is basically used to resize image so you can alternatively define custom image sizes in your function file
    add_image_size( 'post-thumb', 120, 120, true ); //

  15. alexwrld
    Member
    Posted 1 year ago #

    It was developed by Mousumi as a student of web design...So it is her theme that she developed from scratch.

    The same very theme kept working fine for over a year. In the month of October, when one of her artciles was featured on BBC, we have over 10,000 people visiting us in 24 hours. I wonder why we did not have any problem then.
    Switching to another theme will be a huge task. The blog has over 800 posts.

  16. cinghaman
    Member
    Posted 1 year ago #

    Alex no need to switch just a bit of code update will/should work out

  17. alexwrld
    Member
    Posted 1 year ago #

    By the way, I posted the same thread on W3 Total cache but got no response. Can you guys tell me where to find more info on How to set up browser cache and Minify in the same plugin. Ours is active (except minify) but it doesn't seem to be giving us any result.

  18. cinghaman
    Member
    Posted 1 year ago #

    Image like popular tags/ facebook activity/ subscribe can be converted into text (css3/google fonts give good options) - its just a start to reduce the load on your home page as i see that internal pages are ok

  19. alexwrld
    Member
    Posted 1 year ago #

    Thanks for the suggestion cinghaman!

    You know just yesterday, the site was loading in about 7-8 seconds in Gtmetrics. It happened soon after Mousumi fixed w3 validator errors and warnings. It lasted for about 3 hours and then got back to the snail's pace.

  20. cinghaman
    Member
    Posted 1 year ago #

    The best practice could be dumping site on localhost/dev server removing some of the plugins which might not be necessary doing anything on site (sometime we go overboard with plugins for even small small things) overriding timthumb and adding custom functions for image size.
    OR changing from w3 Total cache to WP super cache (just a try)

  21. alexwrld
    Member
    Posted 1 year ago #

    Going to try all your suggestions....dinner time in Delhi (a bit late though)

    Thank you for your time!

  22. cinghaman
    Member
    Posted 1 year ago #

    11:45 Dinner :) enjoy

  23. alexwrld
    Member
    Posted 1 year ago #

    Here it is, after loading for a minute, this is what pops up:

    500 Server Error
    A misconfiguration on the server caused a hiccup. Check the server logs, fix the problem, then try again.

  24. cinghaman
    Member
    Posted 1 year ago #

    Just a random thought what is your memory_limit in php.ini file ?

  25. alexwrld
    Member
    Posted 1 year ago #

    I'm currently chatting with BlueHost support. Here is what he is suggesting: But I'm not getting any hold yet :-(

    Aaron B.:Its the throttling on your account, anything about ~600 seconds is where problems start, and you are over 34,000 seconds.
    (1:12:28am)Aaron B.:Your account is currently being throttled. This generally means there are processes or queries being abusive to the server, and using up a good majority of the servers overall resources. We have information on throttled as well as steps to resolve it here: https://my.bluehost.com/cgi/help/564 If you are unsure how to resolve this, or can't figure it out, you can also send a ticket into the "CPU Exceede Errors" section here: https://my.bluehost.com/cgi/help/ticket

    Another new option that we offer is cloud flare in your cPanel. This is a free and paid service (paid is only necessary if you have an SSL on the domain you are activating it on). This service caches your content on a server that is closer to your intended customer. It also stops processes from starting as the content is already cached with them. In most cases this will drastically cut throttling, or stop it all together.
    (1:12:46am)Udhaw Kumar:A developer gave me the following answer:
    The real reason for that error will be logged within your sites error log. That error usually occurs due to problem with the servers configuration. PHP may also trigger the error if there is a problem in your script. Bluehost should provide a facility for viewing your logs.
    (1:13:35am)Aaron B.:If you log into cPanel, under "logs" there is an "error logs" section, the php section below is what you would want to look at.

  26. cinghaman
    Member
    Posted 1 year ago #

    1: Try removing timthumb and add_image_size function
    2: php.ini memory_limit (usually it is 64M) try increasing to 100
    2: Dump your site on localhost and remove plugins one by one and see the speed difference

  27. alexwrld
    Member
    Posted 1 year ago #

    Working on timthumb but unable to locate php.ini memory_limit

  28. cinghaman
    Member
    Posted 1 year ago #

  29. alexwrld
    Member
    Posted 1 year ago #

    Thanks very much :-)

  30. alexwrld
    Member
    Posted 1 year ago #

    We are working on #2. Meanwhile, you can take a look at http://tinypic.com/r/2rhai5u/6 (CPU Throttling Log)
    The support guy is saying that we need to fix our PHP and MySQL files.

Topic Closed

This topic has been closed to new replies.

About this Topic