WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Migration problem (5 posts)

  1. dsvakola
    Member
    Posted 1 year ago #

    I have transferred my domain http://safehandsakola.org from one server to another.
    I did all the necessary steps i.e.

    • Exported the backup of WP from old server
    • Then I imported that backup to new serer.
    • I tried this process thrice
    • But there is one recurring problem, that every post and comment and all other things are imported correctly, except, the images and the thumbnail images.
    • I had also checked the "File attachment" checkbox also, everytime I did this process.
    • Then I tried one more thing.
    • I took the copy of all "Uploads" folder from old server and uploaded at the correct path inside WP-Content folder on the new server.
    • But still the problem is there.

    Please help, anybody................
    I just love WP and don't want to switchover even due to this problem. For this I reedit all the posts and paste the images required in each post from old server to new one.
    You can imagine, that how cumbersome this process would have been, but still I love WP and don't want to switchover....
    Please help anybody..............

  2. keesiemeijer
    moderator
    Posted 1 year ago #

    Can you see your images in wp-admin > Media > Library?
    Is the upload folder correct in wp-admin > Setttings > Media?
    Did your domain or url change?
    http://codex.wordpress.org/Moving_WordPress#When_Your_Domain_Name_or_URLs_Change

  3. dsvakola
    Member
    Posted 1 year ago #

    No I do not see images in the wp-admin > Media > Library

    The upload folder is correct in wp-admin > Setttings > Media?

    The domain does not change.

    I also tried the complete cpanel backup and restored it on the new domain. Then everything like my emails and the sort works normally, but the WP site doesn't.

    It says, error establishing database connection.

  4. fonglh
    Member
    Posted 1 year ago #

    It says, error establishing database connection.

    That's because your cpanel backup includes the wp-config.php file, which is no longer referring to a valid database server because you changed servers.

    Have you tried correcting the settings?

  5. dsvakola
    Member
    Posted 1 year ago #

    Its all ok now.
    Thanks for support.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.