WordPress.org

Ready to get started?Download WordPress

Forums

migrating to new server -- wp-admin keep redirects to old URL (7 posts)

  1. blakekr
    Member
    Posted 8 years ago #

    I have a question about migrating a complete wordpress installation to a new server. I followed the directions step by step available here:
    http://www.tamba2.org.uk/wordpress/move/

    The site itself displays okay at the new location, but I can't log into the wp-admin there, because it instantly redirects me to the old URL.

    Yet I can't find any trace of the old URL listed in the database or in the files.

    Any ideas where I can find and toggle this setting?

  2. moshu
    Member
    Posted 8 years ago #

    If it redirects... you should check the site_url and home values in the options table. See the guide:
    http://www.tamba2.org.uk/wordpress/site-url/

  3. blakekr
    Member
    Posted 8 years ago #

    Thank you, but as I wrote I used that guide to migrate, and the new URLS are in the database.

    Any other possibilities?

  4. moshu
    Member
    Posted 8 years ago #

    Clear the cache?
    BTW, this is NOT the same guide you used!

  5. Kassad
    Member
    Posted 8 years ago #

    I suppose, it is a wp-2.0 install.
    In this case, you need to delete the content of options in the cache in the wp-content folder.
    Something like this:
    wp-content/cache/c4ca4238a0b923820dcc509a6f75849b/options

  6. blakekr
    Member
    Posted 8 years ago #

    No, I haven't dared to try a WP 2.0 yet. This is just moving a working 1.5.x to another.

    Let me try deleting the cache as you suggest ... good idea, but no it still redirects.

    I have "grep -r" d the entire site looking for an instance of the old URL, but I don't find one. Triple checked home and siteurl, but they have the correct values, as does everything else I see in the options table.

    ???

  7. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    Add the following to wp-config.php:

    define('RELOCATE', true);

    With that set, try to login. WP will detect the new location and update the URLs in the database.

    When you're done, remove the RELOCATE line.

Topic Closed

This topic has been closed to new replies.

About this Topic