WordPress.org

Ready to get started?Download WordPress

Forums

Meta Slider
[resolved] 'Meta Slider' Menu Dissapears from WP Dashboard (17 posts)

  1. simonpedge
    Member
    Posted 1 year ago #

    Hi,
    I recently installed Meta Slider onto a new WP Site. Played around with it and its excellent, and was considering getting the Pro version until I encountered a major problem.

    When I now click the 'Meta Slider' menu on the left-hand side, its just a blank page - the header slider that I created previously still works (http://slddesign.com/blackriver3).
    When I delete the 5 slider images from the WP Media Library, and click on the 'Meta Slider' again, the slider I created is again visible - minus the slides. But if I add any image/s this issue reoccurs.

    I'm not using any other plugins. Although I'm using a custom theme, I've reverted back to the 'Responsive' theme but the issue also occurs in this theme - so its not a theme related problem either.
    I went through your 'The Top 5 Meta Slider Issues' post, but nothing there resolved the issue.
    For my client I'm looking for a slider product that is a) responsive, and b) allows you to define multiple sliders. Your product ticks both boxes, and if you resolve this issue, I'll definately upgrade to the pro version...

    The issue can be found here: http://slddesign.com/blackriver3
    The preview works: Yes
    It works with other themes: Yes
    It works when I disable all other plugins: No
    Meta Slider version: 2.1.6

    Cheers
    Simon

    http://wordpress.org/extend/plugins/ml-slider/

  2. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Simon,

    I investigated this issue yesterday - the short version is your PHP installation is running out of memory.

    Here's what happens:

    Meta Slider loads the latest slideshow in the admin area
    For each slide, it "opens" the image using WP_Image_Editor to check that a 150x150px thumbnail exists (if not, it goes on to create a thumbnail)
    WP_Image_Editor attempts to set the memory_limit setting in PHP to 256mb (this will fail when safe mode is enabled - problem number 1)
    WP_Image_Editor fails silently if it can't open the image (this happens when PHP runs out of memory - problem number 2) and you get a blank screen.

    - Do you have safe mode enabled?
    - How big are the images you're trying to add to the slideshow? My investigations from yesterday tell me that even if the image is 2mb on your computer, when PHP "opens" it, it decompresses it, so that 2mb image might take up 30mb in server memory.

    The solutions (for the moment) are:
    Resize your slides on your computer before uploading them (only if they're huge)
    or
    Disable php safe_mode (better)
    or
    Increase the memory_limit in PHP (best)

    As soon as I can think of a good way to get around this issue I'll add a fix into Meta Slider, at the moment it's quite deep rooted in the WordPress core code, so finding a "nice" way to solve it is proving a bit tricky.

    Regards,
    Tom

  3. simonpedge
    Member
    Posted 1 year ago #

    Hi Tom,
    Thanks for the extremely rapid response - impressive :)

    I just did a 'php_info()' for my site, and I have the following settings:
    safe_mode: off
    memory_limit: 256MB
    The 5 slide images I'm using are the following sizes:
    104kb, 96kb, 98kb,62kb, 87kb

    So safe mode is off already - so you reckon I get the 'memory-limit' setting changed? What to - double (512MB)?

    Cheers
    Simon

  4. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Simon,

    256mb is already quite a lot, and should be enough really. Even if you set it to 512, I think WP_Image_Editor will bring it back down to 256 (it doesn't check to see if the default php.ini value is already higher).

    Do you have a lot of other plugins installed? Could you try disabling them quickly to see if the admin page pops back up?

    Regards,
    Tom.

  5. simonpedge
    Member
    Posted 1 year ago #

    Hi Tom,

    No, no other plugins installed as of yet - this is a new site. I did have vSlider installed, but removed it becuase it was not responsive :(

    Like I said its a child theme of 'Responsive', but I have switched back to the parent 'Responsive' theme and the problem also occurs there.

    The hosting account being used hosts a few test WordPress installations, often some being used simultaneously. Could this be an issue, memory-wise?

    Otherwise, if I gave you a WP admin login, could you have a quick look?

    Cheers
    Simon

  6. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Simon,

    The other sites running on the server might be something to do with it - is it a VPS?

    An admin login won't help too much really, but thanks for the offer. I'm fairly sure it's just running out of memory. Give me an hour or 2 and I'll see if I can work out a fix.

    In the mean time, could you confirm: if you start with a blank slideshow and add say, 5 slides, the slideshow works ok on the front end of your site (correctly displaying the 5 slides), but the admin area doesn't work?

    Thanks
    Tom

  7. simonpedge
    Member
    Posted 1 year ago #

    Hi Tom,
    Regarding VPS - I've got no idea about that. I have just increased the PHP 'memory-limit' to 512MB - check out:
    http://slddesign.com/blackriver3/php_info.php
    This didn't solve the problem.

    Yes, I start with a blank slideshow, and add the 5 slides, and then save. Within a seperate browser tab the slider works perfectly on the front-end - see here: http://slddesign.com/blackriver3/
    Back in the 'WP back-end' browser tab, I can change the settings of the slider, but if I go to another WP Dashboard menu item and then come back to the 'Meta Slider' menu, its all blank (just left-hand side menu of WP dashboard displays - nothing else).
    Have tried logging out, logging in, using a different browser (IE & FF), with no joy.

    Hopefully you can have some success figuring out :)

    Thanks
    Simon

  8. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Simon,

    It shouldn't be anything to do with the theme or anything like that.

    Could you try adding this to your wp-config.php file please?

    define('WP_MEMORY_LIMIT', '256M');

    It seems like the default is 40M, not 256M like I originally thought!

    EDIT: sorry, no.. it's a red herring I think. Back to the drawing board..

    Regards,
    Tom.

  9. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Me again, just noticed you have Image Magick installed which gives me another avenue to look down, it could be using more memory up than GD.

    Back shortly..

    Regards,
    Tom

  10. simonpedge
    Member
    Posted 1 year ago #

    Hi Tom,

    I added the 'WP_MEMORY_LIMIT' line to the 'wp-config.php' file. No joy - the problem still persists.
    I lalso logged out and then logged back into WP in a seperate tab just to make sure (in case above change affects session vars?) - no joy :(

    I'm hoping that the 'Image Magick' module is the issue...

    Cheers
    Simon

  11. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Simon,

    Please try adding this to your themes functions.php file:

    function make_gd_default_image_editor($editors) {
    	return array('WP_Image_Editor_GD','WP_Image_Editor_Imagick');
    }
    add_filter('wp_image_editors', 'make_gd_default_image_editor');

    Hopefully fairly self explanatory, and hopefully GD will use a little less memory up.

    Regards,
    Tom

  12. simonpedge
    Member
    Posted 1 year ago #

    Hi Tom,

    Great, that changed did the trick, and 'Meta Slider' is working perfectly now! :)

    I'll have to remember this little fix for future sites I do in this hosting environment...

    Thanks for all your help Tom.

    Cheers
    Simon

  13. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Very interesting :)

    A few others have had the same problem, I can only get it to happen when I set up a very low memory limit in PHP (a limit so low its unlikely a host would ever set up their server like that), so maybe this is the reason after all.

    Thanks for your help!

    Regards,
    Tom.

  14. simonpedge
    Member
    Posted 1 year ago #

    Yes, hopefully this fix can help these other people out as well.

    Like i said, this is an excellent plugin! I like vSlider as well (I have tried a few others as well), but vSlider is not responsive at all. 'Responsive Slider' works well and is wonderfully responsive, but allows only 1 slider per site.

    Thanks for your plugin and support.

  15. SClassic
    Member
    Posted 1 year ago #

    Hi,

    I found your post most interesting. I have the same issue as Simon. I tried to implement the changes that you mentioned Tom but have had no luck. When I click the Meta Slider menu, it is still blank and in the wordpress dashboard under the plugin section I have the following:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home/superbcl/public_html/wp-includes/SimplePie/Item.php on line 2736

    Can you please offer any suggestions?

    Thanks,

    James

  16. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi James,

    33554432bytes (32mb) memory is very low. WordPress 'wants' 256mb whenever you use the image editor, but your host is limiting it to 32mb, your only/best option is to ask your host to increase it.

    Regards,
    Tom.

  17. SClassic
    Member
    Posted 1 year ago #

    Hi Tom,

    Thanks for your response. I have e-mailed my host. I'll let you knw how I go.

    Regards,

    James

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic