WordPress.org

Ready to get started?Download WordPress

Forums

Meta Slider
[resolved] Meta Slider 2.8-beta stopped sliding after upgrade (13 posts)

  1. ziskam
    Member
    Posted 3 months ago #

    Hi, After doing a complete upgrade of a site (plugins and wordpress) the slider stopped sliding. It's stuck on the first slide and there are no slider arrows or dots.
    - The preview of the slider works.
    - I've checked the code and it looks fine (no added p tags thrown in).
    - I've checked the slider settings and they look fine
    - I'm getting JavaScript errors on the page. I have checked and jquery and the slider scripts are being loaded.
    Errors:
    TypeError: Cannot read property 'msie' of undefined
    http://.../js/jquery.fancybox.pack.js?ver=3.9:5

    TypeError: undefined is not a function
    http://.../js/custom.js?ver=1.0:2

    TypeError: undefined is not a function
    http://...:164&host=janellapurcell.com

    I don't really know where to go from here.

    The issue can be found here: http://janellapurcell.com/
    The preview works: Yes
    It works with other themes: No
    It works when I disable all other plugins: Haven't Tried (It's a live site so can't take it down)
    Meta Slider version: 2.8-beta

    Thanks
    Fran

    https://wordpress.org/plugins/ml-slider/

  2. Matcha Labs
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Fran,

    It looks like you have a couple of problems there. The most obvious is that the flexslider JavaScript isn't being included on your page. Do you have 'Print JS' enabled in the advanced slideshow settings?

    Regards,
    Tom.

  3. ziskam
    Member
    Posted 3 months ago #

    Thanks for the tip.
    I have checked and Print JS, in the advanced setting, is selected.

    Do you know what could stop the javascript from being included? It looks like javascript for other plugins are included. Alternatively, is there a way for me to insert it manually?

    Thanks,
    Fran

  4. ziskam
    Member
    Posted 3 months ago #

    Looking at the last JS error (TypeError: undefined is not a function), it points to this section of the page, specifically the line
    $('#metaslider_1218').flexslider({
    Full script:

    <script type="text/javascript">
            var metaslider_1218 = function($) {
                $('#metaslider_1218').addClass('flexslider'); // theme/plugin conflict avoidance
                $('#metaslider_1218').flexslider({
                    slideshowSpeed:4000,
                    animation:"slide",
                    controlNav:true,
                    directionNav:true,
                    pauseOnHover:true,
                    direction:"horizontal",
                    reverse:false,
                    animationSpeed:600,
                    prevText:"<",
                    nextText:">",
                    easing:"easeInQuad",
                    slideshow:true,
                    useCSS:false
                });
            };
            var timer_metaslider_1218 = function() {
                window.jQuery && jQuery.isReady ? metaslider_1218(window.jQuery) : window.setTimeout(timer_metaslider_1218, 1);
            };
            timer_metaslider_1218();
        </script>

    Is there another JS file that needs to be included beforehand?

    Fran

  5. philly2012
    Member
    Posted 3 months ago #

    Can I join in on this one... my sliders have stopped working too. print JS is checked... any help please

  6. Matcha Labs
    Member
    Plugin Author

    Posted 3 months ago #

    Fran,

    Could you check your themes footer.php file to make sure there it has this line?

    <?php wp_footer(); ?>

    Philly, please can you start a new topic including the details in the 'read this before posting' thread at the top of the forum.

    Regards,
    Tom

  7. philly2012
    Member
    Posted 3 months ago #

    thanks for the reply- I seem to have it sorted with the shortcode wrapped in raw tags... or is this bad practice?

  8. Matcha Labs
    Member
    Plugin Author

    Posted 3 months ago #

    Hi,

    Are you sure? It's not working for me. I can't see the flexslider javascript being included on the page (see my previous reply about wp_footer).

    Raw tags will make no difference unless you're having problems with <p> tags (I don't think you are).

    Regards,
    Tom.

  9. ziskam
    Member
    Posted 3 months ago #

    wp_footer definitely included, just above closing body tag.

    It's adding the metaslider css files ( flexslider.css and public.css ) but no js files.

  10. ziskam
    Member
    Posted 3 months ago #

    It's probably not the best solution but, would it work if I added the metaslider js files to my functions.php file and register/enqueue from there?

    Although, looking at the number of files in there, I'd either have to load them all or know which ones I need and not change the slider settings.

    Fran

  11. Matcha Labs
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Fran,

    That would work, or you could just dump the script tag into your footer.php file.

    It would be better to work out whats actually causing it though. I would start by disabling any other plugins you updated at the same time as meta slider.

    Regards,
    Tom

  12. ziskam
    Member
    Posted 3 months ago #

    Update: I've manually added the script files under the call to wp_footer and now the slider works.

    Not the most optimal solution, but at least it works now!
    I tried disabling other plugins but couldn't work out what was causing the problem.

    Thanks,
    Fran

  13. kitemonkey
    Member
    Posted 3 months ago #

    What I've narrowed down that's causing the issue for me is the latest version of Nextgen, which seems to be mentioned in a couple of posts.

    Tried this on an older dev site I did for someone a while back. Upgraded Metaslider, works fine. Upgrade the Nextgen, Metaslider breaks.

    -note- not suggesting this is a metaslider problem ;-) this may help narrow down what the actual problem is however.

    You can see it in action here :

    http://c2c.twogreenmonkeys.ca/

Reply

You must log in to post.

About this Plugin

About this Topic