WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] meta property og:title (12 posts)

  1. FolkertD
    Member
    Posted 1 year ago #

    Hi,

    Since i updated to yoast 1.4.7 the meta property og:title is not displaying the title template but as the standard title-sitename that should be title template too right?

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. benyhirmansyah
    Member
    Posted 1 year ago #

    I have same problem. After updating to latest version, all post title format has changed to default with additional sitename. There is no sitename with separator in my setting but they stil showed up.

  3. Cavor
    Member
    Posted 1 year ago #

    +1

  4. archon810
    Member
    Posted 1 year ago #

    Came here to file the same bug.

    Example page: http://www.androidpolice.com/2013/04/22/indigo-is-a-voice-assistant-that-knows-how-to-carry-on-a-conversation-like-a-normal-person-or-clever-bot/

    <title>Indigo Is A Voice Assistant That Knows How To Carry On A Conversation Like A Normal Person (Or Clever Bot)</title>

    <meta property='og:title' content='Indigo Is A Voice Assistant That Knows How To Carry On A Conversation Like A Normal Person (Or Clever Bot) - Android Police - Android News, Apps, Games, Phones, Tablets'/>

    Lots of crap at the end of the title, which is only meant for the front page.

  5. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    Bug found and fixed for the next release, you can fix it for your site for now by going into frontend/class-opengraph.php and changing line 32 to:

    $this->options = get_wpseo_options();

  6. archon810
    Member
    Posted 1 year ago #

    Fix confirmed. Thanks, Joost.

  7. delapuravida
    Member
    Posted 1 year ago #

    Hey, I came here thinking this didn't work, but it does.

    So, FYI:
    If anyone else comes here with a similar issue - the above fix, of course, works. The reason mine were still displaying incorrectly is because I had the Yoast SEO title field filled in on some particular pages. That field has to be blank for the settings in Titles & Metas to work.
    duhhh :)

  8. Namli
    Member
    Posted 1 year ago #

    I think you forgot to fix this bug in 1.4.9. Still have to manually change it. Thought I give you a heads up.

  9. Three_Star_Dave
    Member
    Posted 1 year ago #

    Also has to be manually changed in 1.4.10 (but, on the bright side, it works now that I found it in WP's awful support forums).

  10. archon810
    Member
    Posted 1 year ago #

    Same. Though, I just svn updated, so it merged everything and I didn't have to do anything, but I noticed the file is still listed as modified.

    Joooooooost! Let's fix this properly, shall we?

  11. hawkeye73
    Member
    Posted 1 year ago #

    MMM, updates to version 1.4.12 and still not fixed...

  12. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry peeps, this somehow didn't get committed. Just committed it and will add it in the next release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.