WordPress.org

Ready to get started?Download WordPress

Forums

qTranslate META
[resolved] meta fields don't display (12 posts)

  1. christian70
    Member
    Posted 1 year ago #

    hi. i installed this plugin along with qtranslate, which is hugely useful to multi-language sites. the meta fields appear correctly in the backend, for all enabled languages, but checking in displayed pages or posts no meta tags are added. i can't fix it. any hint to get the values from qtranslate meta fields and print them directly in header? many thanks.

    http://wordpress.org/extend/plugins/qtranslate-meta/

  2. christian70
    Member
    Posted 1 year ago #

    i make an attempt by re-installing the plugin and now everything seems to work well. i love it, quite essential and easier than complicated seo plugins.

  3. lull
    Member
    Posted 1 year ago #

    Do you have the meta description in your code source for the home page ?
    I don't have, and want this...
    It's ok for all the page and post, but not for the home page. I use a page with qtranslate meta.

  4. christian70
    Member
    Posted 1 year ago #

    honestly i use a specific front-page as home-page, so i added static meta tags manually in it.

  5. lull
    Member
    Posted 1 year ago #

    ok thanks ! I looking for the solution

  6. Greg007
    Member
    Posted 8 months ago #

    @luli "Do you have the meta description in your code source for the home page ?
    It's ok for all the page and post, but not for the home page"

    Are you sure about this?
    You are suggesting that it is better to have it in code source than just to set it via this plugin??!

  7. Greg007
    Member
    Posted 8 months ago #

    I installed qTranslate META, but no meta fields in the backend anywhere.
    I reinstalled, but again the same.

    I am on WP 3.6.

    I had All in one SEO, and SEO by YOST, by they are not installed (YOST) or active (all in one seo).
    Could it be that they are making problems, although they are not active.

    Where should this qTranslate META field be?
    I have 4 pages in 4 languages, should it be there when I open a page to edit it?!

  8. christian70
    Member
    Posted 8 months ago #

    the qtranslate meta field is supposed to appear beneath the main content in all your pages and posts in the backend, obviously. just be sure on your screen options (check it out in the hidden panel above). i've never used seo by yost, i've always made it by myself by using qtranslate and qtranslate slug plugins. now for the newer versions of wp i quit also qtranslate meta plugin, because i'm using the excerpt field (native with wp) as meta description field (it comes to be naturally available in all languages installed with qtranslate): i've just renamed it as 'metadescription max 160 characters' in php functions and made it display in the header of my pages or posts. i quit any meta keywords field because they are almost useless nowadays.

  9. Greg007
    Member
    Posted 8 months ago #

    christian70, thank you very much, qtranslate meta field is under the main content indeed, I didn't saw it there! :))

    All-in-one-seo and seo-by-yost plugins add meta fields on the right side of the screen as soon as you open "all pages" (you can set it there without opening the page itself),
    so I though the qtranslate meta fields should be there also (although no reason to think that way) :)

    So now I made some progress with my website :), although I have problem with setting page title for HOME PAGE.
    My home page is in fact a post with a table with prices and some text,
    and I didn't set any title for this post because title and tagline are set in theme that I am using (themify theme).

    By default, title of the home page is the site title but without tagline, and seo-by-yost and all-in-one-seo plugin added tagline immediately to page title.

    Now I set it the way I want it in the qtranslate meta field, but I still get only site name as page title for the home page (tagline is not displayed).

    What am I doing wrong? Did anybody understood my problem... :)

  10. Greg007
    Member
    Posted 8 months ago #

    OK, I localized my problem with home page.
    Permalink of my homepage is http://www.my-website.com/164
    And when I open that address, my home page title is as I set it!

    Bun when I open http://www.my-website.com, I get only website title as my homepage title.

    How to solve this?
    How to set the home page link to be http://www.my-website.com, not http://www.my-website.com/164
    In Permalink Settings, Post name is choosen!

  11. Greg007
    Member
    Posted 8 months ago #

    OK, I didn't know that vvv.my-website.com will actually open a real website.
    :)
    That is not my website... :))

  12. christian70
    Member
    Posted 8 months ago #

    i guess this is not the right place to talk about homepages and permalinks. anyway for what i've understood you can't set a post as homepage. you can decide either to choose a static page as homepage or show all posts on it. i've always coded my own homepage in a front-page.php file, so i might be wrong. besides i suggest you to change the permalink settings from numbers to slugs according to seo rules.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.