WordPress.org

Ready to get started?Download WordPress

Forums

Meta desscription missing in the source code (5 posts)

  1. strafs
    Member
    Posted 1 year ago #

    Hello everybody,
    I'm having troubles using the WordPress SEO by Yoast plugin on one of my sites: meta descriptions I've entered are not showed in the page source code. In the source code there's only a string text which says: <meta name="description" content="" />.

    There was a red alert on the plugin dashboard which said that something like “your theme contains a meta description that makes wordpress seo plugin works not correctly. Please delete this line or press the “fix it” button <meta name=”description” content=”<?php bloginfo( ‘description’ ); ?>” />.
    So I canceled that line, the red alert gone away, but meta description are not showed again: now is missing also the line <meta description= content ""> that there was before...
    I really don't know what to do. The theme developer (Sofa Suppastore by Theme Forest) said to write to Yoast, but Yoast seems not to offer support for free plugins anymore.

    Anyone can please help me?

    Thank you very much

    Luca

    http://www.sexolutions.net

  2. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    right now, there are 2 meta description tags in the output of your site; one empty as you described, the other probably from the seo plugin, with some content.

    repeat this:

    Please delete this line or press the “fix it” button <meta name=”description” content=”<?php bloginfo( ‘description’ ); ?>” />.
    and delete the corresponding line from header.php (?) of your theme.

    for details, please contact your theme's developer for support;

    http://codex.wordpress.org/Forum_Welcome#Commercial_Products

  3. strafs
    Member
    Posted 1 year ago #

    Hi Alchymyth,
    thank you for your prompt reply. Actually I didn't notice there were two meta desc in the site output. So the lower one is the right one, right? Now i canceled the line <meta name=”description” content=”<?php bloginfo( ‘description’ ); ?>” /> and the meta description seems to be just one. But now I notice that there are also two output titles...is that a problem? Do I have to do something to solve also this?

    Thank you again, best regards

    Luca

  4. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    I see only the one meta <title> tag -

    if you think there might be a problem, please contact your theme's developer for support.

  5. strafs
    Member
    Posted 1 year ago #

    There's the one in the upper part of the screen and the one in the middle...and also on products pages meta description are duplicated in the middle part of the source code...anyway I'm also contacting again the theme developer, hoping he can help me to solve this.
    Thank you

Topic Closed

This topic has been closed to new replies.

About this Topic