WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Meta Description showing different words to what I write? (7 posts)

  1. clarelarge
    Member
    Posted 1 year ago #

    Hi,

    I have just built a site http://bistroverde.co.uk

    I have added in at the bottom of each page and the 1 post that is on the home page, the SEO title, and the meta description.

    But then when you type in 'bistro verde' in to google, these nice descriptions do NOT show.

    For example on this page : http://www.bistroverde.co.uk/dessert

    my description is:

    "Our Dessert Menu at Bistro Verde is always reinventing itself and we have a great selection of sweets, liqueurs and lots more! Book a table today!"

    yet on google, the results show this:

    "Bistro Verde · HOME · MENUS · Lunch · À La Carte · Dessert · Christmas ... READ OUR REVIEWS. best seafood restaurant in aberdeen scotland bistro verde."

    which is clearly NOT cool, NOT what I want, etc.

    Does any one know how to please fix this??

    I just have all the default values set in the titles and metas area, but the SEO Title words that I have put in at the bottom of each page DO work... it's just the descriptions that do not.

    Hope someone can help, thank you so much :-)

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Elja
    Member
    Posted 1 year ago #

    I just had the same problem. And I resolved it by 2 of three times clicking on the option in the settings to rewrite the titles.

  3. clarelarge
    Member
    Posted 1 year ago #

    Hi Elja,

    Thanks for the reply. What exactly did you click? I went to settings - general (saved them) - writing, reading and permalinks and saved them -

    as sometimes this sorts stuff out - but it is now showing different things again?!!

    haha, so if I do site:bistroverde.co.uk then the dessert page is NOW showing :

    Warm Chocolate Fondant served with Vanilla Ice Cream. £6.95. Chefs Cheesecake of the Day served with Fruit Coulis. £5.95. Chefs Crème Brûlée of the Day ...

    hahaha - which also isn't want it should be showing, but a bit better than before, but just looks like I've not bothered to write anything decent...

    but I HAVE :-(

    if anyone can help that'd be great :-)

    Clare :-)

  4. Elja
    Member
    Posted 1 year ago #

    Hi Clare,

    I have the plugin in Dutch language, So I don´t know how things are called in other languages. But I try to describe. Go to

    SEO settings
    Titles and Meta´s
    Title Settings (first box) rewrite titles -> On
    Save

  5. clarelarge
    Member
    Posted 1 year ago #

    Hi Elja,

    That's great thank you. I tried that, and saved it, and it still doesn't seem to do it.

    If you type site:bistroverde.co.uk into ANY google search on any browser, it still pulls random text from the pages, NOT my exact descriptions?

    It has the SEO Title perfect, just not the descriptions.

    Very weird. Hope someone can help?? :-)

  6. Elja
    Member
    Posted 1 year ago #

    You can look what google can see on a page of your website, and what description and title is produced on your site.

    Look at the html code in your site. You can do that in your browser.

    When I do that, I see, I think the good description produced by Yoast.

    But I can see that you have the meta tag description and title tag Twice on the page (meta name="description" )

    And I think Google takes the first one of your page.

    So, do you have another plugin that produces title and description tags?
    I think sometimes it is the theme that produces these meta tags.
    Look at that, and try to stop that.

    But I am using WordPress for 2 weeks now, so I am not an expert.

  7. carra23
    Member
    Posted 1 year ago #

    I have a very similar problem.

    I'll try checking the re-write titles option and see what happens.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic