WordPress.org

Ready to get started?Download WordPress

Forums

Meta Description not showing up in google results (4 posts)

  1. MPenguin
    Member
    Posted 4 years ago #

    If you do a google search for "taiwan expatriate" my blog comes up on the first page (it is http://www.expatintaiwan.net).

    http://www.google.com/search?hl=en&safe=off&q=taiwan+expatriate&btnG=Search&aq=f&oq=&aqi=

    However, there is no Meta Description tag. Why?

    I'm using WordPress 2.8.5, Atahualpa Theme, All-in-One SEO, and have all both the Description on the AIO SEO and Atahualpa theme options set correctly. But it's still not showing up.

    If I look at the source code of my page, I can see the meta description in the AIO SEO section, but it still doesn't show up in Google. Can someone explain to me why and what I need to do to get it to show? Thanks.

  2. amleon2007
    Member
    Posted 4 years ago #

    I am having the same issue and found the following:

    If you view the themes > header.php file in dreamweaver, the content you see in dreamweaver does not display everything you can see by 'viewing source' in a web browser.

    1). View source in a web browser shows that a line of code was added disallowing robots from crawling the site:
    <meta name='robots' content='noindex,nofollow' />

    2). Opening header.php in dreamweaver does not even show this information

    I am currently trying to locate which file on the server contains this line of code in order to remove it. No success as of yet.

  3. amleon2007
    Member
    Posted 4 years ago #

    Found it!

    See this thread located here:
    http://wordpress.org/support/topic/283602?replies=6

    or go to your privacy setting in the admin panel and select all others can view this site including bots....

  4. alism
    Member
    Posted 4 years ago #

    Admin > Settings > Privacy, then change it to "I would like my blog to be visible to everyone, including search engines (like Google, Bing, Technorati) and archivers".

Topic Closed

This topic has been closed to new replies.

About this Topic