WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Meta data reports a wrong image Date/Time in photo list (3 posts)

  1. JohanPirlouit
    Member
    Posted 8 months ago #

    Hi everyone, hi Photocrati,

    When I upload new photos in any gallery, the Date/Time shown in the gallery list is not the Date/Time from the meta data but is the Date/Time of the day I upload photos to the NGG gallery...

    A few weeks ago there has been a bug in the early 2.0 versions that set the year to 1970, it has been fixed (I don't find the thread that talked about it), but something is back with version 2.0.33 (tested with WP 3.7.1 and WP 3.6.1).

    It is like NGG doesn't correctly read the EXIF DateTimeOriginal tag anymore when uploading new photos or when updating meta datas... By the way, the Show meta data window shows all correct meta datas (EXIF, IPTC and even some XMP)!

    Is it a bug, a regression, a mis-configuration that I coud do? Any ideas?

    Regards,
    Johan

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 8 months ago #

    @JohanPirlouit - If you could try the following:

    Go to Gallery > Manage Galleries ... select the gallery (or galleries) where the meta data needs to be addressed. Choose "Import metadata" from the Bulk action list and click < Apply >.

    We'd like to know what is going on with your site, especially if that does not work for you, so if you could submit a Bug Report (http://www.nextgen-gallery.com/report-bug/ ... please reference this topic) and include log in credentials with the report so we can get a closer look we would like to help you get this sorted out.

    Thanks!

    - Cais.

  3. JohanPirlouit
    Member
    Posted 8 months ago #

    Hi,

    Bulk Import metadata does nothing... All Meta Datas are already saved during upload. I did tests with a fresh WP 3.7.1 install, no other plugins and with all previous public NGG releases since 2.0.0 and here are the results:
    - From 2.0.0 to 2.0.21: Meta Datas are saved at upload and the Date/Time is correctly reported in the list.
    - 2.0.23 and 2.0.24: Meta Datas are not saved at upload, Date/Time report is the upload date. A bulk Import metadata does correctly save Meta Datas and reports the right EXIF DateTimeOriginal tag.
    - 2.0.25: the bug is fixed, Meta Datas are saved at upload and the Date/Time is correctly reported in the list.
    - 2.0.27: regression, the bug reappears as for 2.0.23 and 2.0.24.
    - Since 2.0.30: the bug is partially fixed: Meta Datas are correctly saved at upload but Date/Time report is the upload date. A bulk Import metadata changes nothing.

    Steps to reproduce:
    - Install NGG
    - Create Gallery
    - Upload Photo
    - Go to Manage Galleries -> open the created gallery and see photo information in the list.

    And as you asked me to do, I opened a Bug Report with my personal dev server details (because my website is still under developpement and it is not currently online)... I hope it is not a configuration problem with my server...

    Regards,
    Johan

Reply

You must log in to post.

About this Plugin

About this Topic