WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Messed up my RSS FEED (12 posts)

  1. tecnofaqs
    Member
    Posted 1 year ago #

    Well, I've just changed my permalink structure to /%postname%/ and my RSS Feed is not working, the RSS is this one http://www.tecnofaqs.com/feed or http://www.tecnofaqs.com/feed/atom, it displays a blank page.

    In the feed validator: http://validator.w3.org/feed/check.cgi?url=http://www.tecnofaqs.com/feed/

    This feed does not validate.
    line 1, column 0: XML parsing error: <unknown>:1:0: no element found [help]

    It used to work normally before this permalink's change. Please, I really need your help guys, thank you!!!

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    Is the rest of your site functioning fine on the new permalinks?

    I'm not sure switching permalinks should mess up the feed... but, have you made a new post since switching permalinks? If not, try that - it causes your feed to rebuild (just a quick post - you can delete it after testing)

  3. tecnofaqs
    Member
    Posted 1 year ago #

    yes, I've made some new posts and the my twitterfeed and facebook redirect weren't working, so I decided to check my rss feed and it was the cause of the twitter and facebook redirect not working though.

    Yes, it is working ok the rest of the site and the feed used to work before this permalink's change.

    ps: sorry about my english.

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    If you set your permalinks back to default, does your feed work again?

  5. tecnofaqs
    Member
    Posted 1 year ago #

    I just tried it and still not working.

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    HM.. OK, then we gotta dig a bit

    Have you tried deactivating all p[lugins and switching to 2011 theme?

    Conflicts can randomly arise, especially after a permalink change

  7. tecnofaqs
    Member
    Posted 1 year ago #

    Thank you so much, it was one plugin "Advanced Permalink", well, it was helping me maintain my old links from my old permalink structure... will the new permalink structure be reindexed?

    Thank you for your help, sir.

  8. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    AFAIK, when you change permalinks, the old ponits to the new

    So if you have old permalinks out there you've shared, they will still point to the same place

    And as google crawls your site, your new stuff will get indexed

    I changed over 3 sites a while back, when use of /postname/ became acceptable - everything worked out for me

  9. tecnofaqs
    Member
    Posted 1 year ago #

    Well, it is not working for me, I mean, posts from facebook and twitter. :(

  10. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

  11. tecnofaqs
    Member
    Posted 1 year ago #

    And you saved my life again.

    It worked, btw, I pasted the code in the 1st line of my htacess, is this correct?

    Thank you again...

  12. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    Yeah, I believe that is correct... up above the WP stuff.... if it's working for you, it's correct, right!?

Topic Closed

This topic has been closed to new replies.

About this Topic