WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Messed up editor with 3.7 update (44 posts)

  1. Dave Naylor
    Member
    Posted 10 months ago #

    I just replicated this issue with a captioned image using the visual editor.

    Temp fix. Put this in your theme's functions.php

    function caption_off() {
        return true;
    }
    
    add_filter( 'disable_captions', 'caption_off' );
  2. rogstamp
    Member
    Posted 10 months ago #

    Will that turn off captions ?

  3. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    @WPRanger - yep me too. Can you post a trac ticket on this?

  4. TKServer
    Member
    Posted 10 months ago #

    The caption property is adding 10,000 pixels to the width!

    I posted one image which was 225px and another which was 300px. Each caption is showing up as 10225px wide and 10300px wide respectively.

  5. rogstamp
    Member
    Posted 10 months ago #

    Sorry being dim, just looked at the code and it's pretty obvious it will turn them off !

  6. Dave Naylor
    Member
    Posted 10 months ago #

  7. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    Thanks very much :)!

  8. rogstamp
    Member
    Posted 10 months ago #

    How long does it usually take for bugs like this to be addressed please ?

  9. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    They're working on it - no way to predict a timeline.

  10. pen4hire
    Member
    Posted 10 months ago #

    I have the same problem. Tried deactivating plugins, tried different themes. Neither made a difference. Tried the temporary fix of clicking Update on the picture, which worked temporarily, but reverted when I saved the whole post.

    Glad I don't have a more serious problem that is shutting down my entire site, but I'd really like to get back to normal.

  11. Andrew
    Forum Moderator
    Posted 10 months ago #

    We'll just have to wait.

  12. rogstamp
    Member
    Posted 10 months ago #

  13. littlerick
    Member
    Posted 10 months ago #

    I found out that if the theme is too old, it won't work with WordPress 3.7

  14. rogstamp
    Member
    Posted 10 months ago #

    Thanks for telling us....

    Marking this resolved as the new update fixed the problem. Thanks all who helped.

Reply

You must log in to post.

About this Topic

Tags

No tags yet.