WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Messed Up (4 posts)

  1. Donald Loyd
    Member
    Posted 9 months ago #

    I was trying to secure my web site on the top line of the information I added http://.
    initially just the name of the site was there example: messed up.com and I can no longer get into my admin page.
    help!

    http://wordpress.org/plugins/wordpress-https/

  2. Lindsayloub
    Member
    Posted 9 months ago #

    I am also locked out of my admin page and have tried both recommended solutions in the FAQ reset the plug-in section and it is still not working! Help!

  3. Lindsayloub
    Member
    Posted 9 months ago #

    Hi Donald,

    I managed to fix the issue. Try this:

    1. Clear your cache on all of the browsers you use, so that maybe internet explorer, mozilla and google chrome

    2. Now, find the php file 'wordpress-https.php'. This should be on your host directory with the path: /wp-content/plugins/wordpress-https/

    3. If you find this, then find the line:
    //define('WPHTTPS_RESET', true);

    If you find this, delete the // to make it:
    define('WPHTTPS_RESET', true);

    Save this change, and then do as the blog said and try and access some of the other pages, while doing this, have a look at the urls of the pages you are now hitting, do they say http://... or https://
    As a clue, with the force ssl working they should all be saying https. (meaning they are now secure encrypted pages)

    4. So, when you are hitting pages now you should be seeing them all with http:// as we have not recommented the change yet.

    5. Try to log in to the admin panel now (remember we still have not recommented out the change yet)

    6. If you can log in now, this is good as it means the force ssl has not permanently changed your wp admin settings

    7. Go back to 'wordpress-https.php' and put the two // back into so it is again commented out and save.

    8. Clear the cache, clear recent browser history, close the browser altogether.

    9. Re open the browser, and try to login to the admin panel. If you can now log in, GREAT, check links on the site, they should all be https meaning your https plugin is working.

    Let me know if this works. Good luck
    Lindsay

  4. Donald Loyd
    Member
    Posted 9 months ago #

    Great job!
    I must admit I did find a solution today.
    I called Go Daddy and paid them to restore the database to the previous day before I messed up.
    One lesson I did learn is to backup your database.
    Thanks,
    Don

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.