WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Message area (textarea) not showing up (13 posts)

  1. clairenooga
    Member
    Posted 1 year ago #

    I have a message area with the correct [textarea message] setup in settings, but on the actual contact page the message form area doesn't show up? See here: http://www.clairewickenden.com/contact-us/

    http://wordpress.org/extend/plugins/contact-form-7/

  2. beffy7
    Member
    Posted 1 year ago #

    I am having the same issue:

    http://sagecaretherapy.com/patient-referral-form/

    The site was created on another domain and everything worked properly. I've recently moved the site and all the text areas are blank. I hope I don't have to redo them all, as the form is really long!

    Someone, please help :) Thanks

  3. davejampole
    Member
    Posted 1 year ago #

    Place this code segment at the bottom of your theme stylesheet (style.css) to set the border style, radius and background color of your text area. Change parameters as desired.

    /* sets CF7 textarea border and fill color */
    .wpcf7 input[type=text], .wpcf7 textarea {
    	border: 1px solid #A0A0A0;
    	border-radius:5px;
            background:#CCE5FF;
    }
  4. clairenooga
    Member
    Posted 1 year ago #

    @davejampole: That didn't fix it... hmm..

  5. davejampole
    Member
    Posted 1 year ago #

    Have you tried using the WP default theme to see if there is a conflict between CF7 and your theme? The code I posted does work with my theme, so I know it is good. Also, are you running the latest versions of WP and CF7?

    PS - Claire, Your theme looks superb.

  6. clairenooga
    Member
    Posted 1 year ago #

    No, I haven't tried that but I find it odd because one minute it was showing up, and then I edited the form and added * to make it required which is when I noticed it disappeared. I then removed the asterisk but it didn't come back. I am running the latest versions of everything. And thank you!

  7. davejampole
    Member
    Posted 1 year ago #

    Last though - create a new form, setting it up exactly as the problem form. If that works, simply delete the problem form. I've had stranger problems and the solutions defied logic.

  8. clairenooga
    Member
    Posted 1 year ago #

    @davejampole - Ok, thanks for your help... that didn't work either, so I just set it as [text] instead of [textarea] and that didn't even work so I'm thinking maybe there's a limit to how many text boxes it allows or something? Any clue?

  9. clairenooga
    Member
    Posted 1 year ago #

    Ok wow. Figured it out! I guess it just doesn't allow the word "message" in [textarea message] for some reason, because I changed it to [textarea message-area] and now it's working just fine! Phew!

  10. davejampole
    Member
    Posted 1 year ago #

    Glad you figured it out! If you've every done any handcoding, you know that all languages have what they call 'reserved words' that have special meaning to that language and cannot be used in any other way. It looks like you ran into one of those.

  11. ale
    Member
    Posted 1 year ago #

    @clairenooga Hi! maybe you can help me! I saw your website - really cool- I'm wondering how did you format the form to show up in two columns?
    thanks!

  12. clairenooga
    Member
    Posted 1 year ago #

    Hi @alepamo - thanks so much. To have two columns just see this thread, it will explain how to do it!
    http://wordpress.org/support/topic/plugin-contact-form-7-adjusting-the-layout?replies=10

  13. ale
    Member
    Posted 1 year ago #

    thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic