WordPress.org

Ready to get started?Download WordPress

Forums

MesoColumn
Mesocloumn, blurry fonts in menu bar (5 posts)

  1. CampBulletin
    Member
    Posted 5 months ago #

    I am using the Mesocolumn theme and having problems with the fonts being blurry. The fonts in the top menu bar just do not look sharp. The same is true for the drop down menu in the second menu bar.

    I have opened on different os, browsers, and devices and there are some changes but seems to be a problem across the board so I am a bit confused as to why. What is even more strange is the best looking one is on a kindle.

    Really would like to use this theme but would like to guarantee the quality will be excellent with no concerns.

    Thanks for any help or suggestions and have a great day!!!

  2. Richie KS
    Member
    Theme Author

    Posted 5 months ago #

    font look allright and sharp to me
    no blurry detected. unless you're using a google web font that tend to look blurry. nothing i can do there.

    try using normal font in font option like arial, verdana etc

  3. Miko
    Member
    Posted 5 months ago #

    CampBulletin: You will experience this if you are using one of the Google Fonts that does not have a bold weight associated. For example, the font Actor has only weight 400 (normal), but the Mesocolumn options-css.php file and the superfish menu css assigns the weight of 600 (semi-bold) to headers and font-style: bold to menus. Furthermore, most browsers by default assign all headers a weight of 700 (bold), so the blurriness is due to your browser 'fake bolding' typefaces which do not have a proper bold style defined. That's probably why the Kindle looks OK (as it doesn't have the built-in bolding, I'd guess).

    If you definitely want crisp fonts, and definitely want to use a Google Font, you have 2 choices:

    OPTION A) Choose a Google Font that has a 600 & 700 weight option. You can see which ones do by heading over to http://www.google.com/fonts and look for ones which say they have 14 styles (you can click to see all the variants).

    OPTION B) If you are confident with code, you could alter your css to override the theme's enforced semi-bold / bold settings.

    @Richie KS: I would strongly recommend any future releases of the theme do not make use of !important bolding hard-baked into your heading/menu styles to allow maximum flexibility. I've been trying to un-force this and it's been a lot of investigative trial & error.

    There's a great post on this very topic here: http://css-tricks.com/watch-your-font-weight/

  4. Miko
    Member
    Posted 5 months ago #

    By the way, the superfish.css overrules any changes I make in style.css (even if I use !important), so I've had to edit the actual superfish.css rather than use my child theme's style.css... @CampBulletin, save yourself the headache and choose a font with 600/700 weights.

  5. CampBulletin
    Member
    Posted 5 months ago #

    Thanks Miko, and Richie

    That was a lot of help thanks a lot. Also thanks for taking the time to give such a great description. That will go into my, I have learned something new today folder.

    Thanks also to Richie for the help and a great theme!

Reply

You must log in to post.

About this Theme

About this Topic