WordPress.org

Ready to get started?Download WordPress

Forums

Openstrap
[resolved] Menus with sub-menus not working. (6 posts)

  1. Seima
    Member
    Posted 6 months ago #

    I have created a primary menu with sub menus but nothing happens when a click on the menu that has a sub menu below. the last sub menu in the menu list worsk but not their parents.

    You can try to click on the menupost called "Produkter" and the sub menus below that one that also have sub menus on the webbsite.

    Any suggestions on how to make the menuposts that has a submenu to work?

  2. Seima
    Member
    Posted 6 months ago #

    Ooops! i forgot the link

  3. Pavan Solapure
    Member
    Theme Author

    Posted 6 months ago #

    Hi Seima,
    Its restriction from bootstrap frmework. But if you are open for JQuery Solution then you can add following to your functions.php (line # 795)

    <script type='text/javascript'>
    jQuery(document).ready( function($) {
    	$("body").delegate("a.dropdown-toggle", "click", function(e) {
    		e.preventDefault();
    		$(location).attr('href', $(this).attr("href"));
    	});
    });
    </script>
  4. Seima
    Member
    Posted 5 months ago #

    Thanks, that did the magic :)

  5. kramr10
    Member
    Posted 5 months ago #

    Unfortunately I'm all too familiar with using the editor. I'm not sure how to find line #795 in functions.php. Can you give me some direction in the best way to find this line so I can add that?

  6. Pavan Solapure
    Member
    Theme Author

    Posted 4 months ago #

    Latest release, 1.0.6 which will be soon available on WP repository has a configuration setting that will allow you to enable/disable the feature.

    Please keep watch.

Reply

You must log in to post.

About this Theme

About this Topic