WordPress.org

Ready to get started?Download WordPress

Forums

Menus limit to 90 items in database ? (8 posts)

  1. soamz
    Member
    Posted 11 months ago #

    We have a new wordpress site, where our menu items are around 136 .

    Now when we started adding the items and drop down items, after 90 items, whatever we do or save, it get deleted.

    So, whats the story ?

    Is wordpress coded to allow only 90 menu items ? Sounds like a joke to me!

    Let me know.

  2. bemdesign
    Member
    Posted 11 months ago #

    It's a PHP limitation (for valid security reasons).
    You will either need to add this code to your .htaccess file (if your host allows you to):

    php_value suhosin.post.max_vars 7000
    php_value suhosin.request.max_vars 7000

    (adjust value as needed, 0=unlimited so be careful with that).

    The other option is to adjust a global PHP setting in your PHP.ini file (likely only your host can do this and they may have valid security reasons for *not* changing this).
    max_input_vars = 9000
    (Adjust value as needed).

    Now the whys of all this can be found in this more in-depth overview:
    http://sevenspark.com/wordpress/menu-item-limit

    Finally, from a usability point of view, consider re-organizing your material so it isn't as large or complex and likely to bump into this issue.

  3. esmi
    Forum Moderator
    Posted 11 months ago #

    Is wordpress coded to allow only 90 menu items ?

    No. WordPress does not impose any limits - but your server might. See http://core.trac.wordpress.org/ticket/14134

  4. Diogo
    Member
    Posted 11 months ago #

    This is actually not an issue with WP itself, but it is actually a symptom of WordPress hitting the limits that PHP has as default.

    Here's a more detailed explanation and solution: The WordPress Menu Item Limit or: Help! Half my menu items just disappeared!

    Cheers

  5. soamz
    Member
    Posted 10 months ago #

    Here is what my host just replied

    I would be happy to implement this fix for you. I do not show that your
    php.ini currently has a "max_input_vars" setting set. I see that the
    article you linked recommends setting this to a value of 3000 to be safe,
    while mentioning that 2000 would probably work for most servers. Please
    confirm where you would like this value set and I will add the line to your
    php.ini to attempt to resolve the error.

    I have added the max_input_vars settting that he suggested into your
    php configuration if you would like to test things out.

    And I just tested the menu addition on my backend, still it doesnt work.

    After 90, it doesnt accept anymore item.

    How do we debug this now ?

  6. Diogo
    Member
    Posted 10 months ago #

    I'm sorry to hear that. Could you do us a favor? To better debug this it would be very useful to get some information from the php_info() function.

    If you can upload files directly to your server, simply create a file named info.php with the following contents:

    <?php
    
    phpinfo();
    
    ?>

    Upload the file to your web root and access it with your browser. It will output a lot of information, search for the max_input_vars and let us know what value is listed there. While on it, see if there are other related vars (request.max_vars, post.max_vars), and also let us know.

    The php_info() function might output some sensitive information, so it is not a good idea to leave the file in your server for too long.

    Hope it helps!

  7. soamz
    Member
    Posted 10 months ago #

  8. Diogo
    Member
    Posted 10 months ago #

    Hey! Good stuff!

    Looks like there's another piece of configuration that needs to be added to the php.ini. Your server appears to be running the Suhosin Extension, and there are some specific configuration need in this case. bemdesign mentions it above, and there are also some clues in the article I referred. Basically, you have to add the info bellow to your php.ini:

    suhosin.post.max_vars = 3000
    suhosin.request.max_vars = 3000

    Let us know if it works!

Reply

You must log in to post.

About this Topic

Tags

No tags yet.