WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Menu shows just Roles and Uninstall (6 posts)

  1. heathz
    Member
    Posted 1 year ago #

    hi guys... I installed the gallery from administration page of my wordpress site but the menu "Gallery" just shows "Roles" and "Reset/Uninstall" opitions... no "Add Gallery" nothing...

    any ideas?

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. CrimsonMoon
    Member
    Posted 1 year ago #

    Same problem here...

  3. smigliorato
    Member
    Posted 1 year ago #

    This could be tricky.

    Have you tried enabling and disabling?

    Uninstall and reinstall?

    Did the plugin ever work on your site?

    If it did work at one time, what has changed since? (Plugin/Theme update/install)

    Lastly, what theme are you using?

    Since we have two instances of the issue, we might be able to cross-reference and track down the bug.

  4. heathz
    Member
    Posted 1 year ago #

    Have you tried enabling and disabling?
    YES I TRIED...
    Uninstall and reinstall?
    DID IT RIGHT NOW! AND STILL NOTHING
    Did the plugin ever work on your site?
    NEVER
    If it did work at one time, what has changed since? (Plugin/Theme update/install)
    ---
    Lastly, what theme are you using?
    THE NAME OF THE THEME IS GAMEPRESS... (http://wordpress.org/extend/themes/gamepress)

  5. smigliorato
    Member
    Posted 1 year ago #

    I installed gamepress and nextgen on a test wordpress install I have.

    It works, so that rules out the theme.

    -----------------

    A bit of digging in the code and it looks like this is a roles/permissions issue.

    Are you the only user of your wordpress install, and you installed it yourself?

    If you go to the NextGen roles section, it allows you to select the lowest role that is allowed to do which action.

    Go to wordpress Users->All Users menu. Check what you role is (there are 5). If your the only one, you should be admin.

    Then, go to NextGen Gallery->Roles. Since you probably want to be able to access everything make sure all the settings are at your role, or lower (if you want to give other people access).

    The order is this, from most capability to least:

    Admin
    Editor
    Author
    Contributor
    Subscriber

    If you have other users, figure out who should have access and set everything up accordingly.

    -----------------

    If that doesn't work, it may be a bug in another plugin or the wordpress install, affecting user roles...

    I want you to test something. Make sure your logged in as admin and nextgen is installed.

    Go to this address, replacing the bit with your web address:

    http://*YOUR WP URL*/wp-admin/admin.php?page=nextgen-gallery

    Make sure, if wp is installed in a subdirectory, to include that too.

  6. CrimsonMoon
    Member
    Posted 1 year ago #

    I too have disabled/enabled and uninstalled/installed, but there was no change. I just checked the Roles settings, and everything is set to Administrator, which is what I'm signed in as. My theme is a custom adaptation of the default WordPress 2012 theme. Must be one of my other plugins that's causing the issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.