WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Menu remains in default language (5 posts)

  1. Antonio Silva
    Member
    Posted 1 year ago #

    Allo,
    It's been a couple days that I'm trying to figure why I can't have my menu and ThemeFront page upadted in the language I pick. I have went over all blogs relative to that topic but can't find anything wrong in my setup. The only point that I have not seen on any blog is if anybody is using Polylang with a WordPress connected to a PostgreSql database. I'm wondering if this is not my main problem.
    I did follow all the steps, I verified the following:
    - Theme Used "Responsive" which is compatible with Polylang. Did test with twentytwelve and it does the same.
    - Header.php have

    <?php wp_nav_menu(array('container'       => 'div',
      'container_class'	=> 'main-nav',
      'fallback_cb'	  =>  'responsive_fallback_menu',
      'theme_location'  => 'header-menu')); ?>

    - I did set the slug with no suffix for default (en) and fr for french for every pages and posts, and set permalink and set it at custom structure /%postname%/
    - I can't see any menu under Settings->languages-> so I tried to use an xml file to call the Hearder menu but does not show up
    - I do see a "Responsive/Feature_content" entry in Settings->languages-> but it is strictly applied to the english version as for my french it goes to Wp_front_page instead.

    Of course If I press on English or french (depending on what I set as default) the language never switch on the menu bar!!!

    Here my link :http://rivalsolutions.com/indexTest.php/

    Anybody can help ??? can I write manual entries in the db or a php code that do a workaround as I already lost a week at trying to figure it out!
    Big thanks
    Anto

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I was not aware that we could use PostgreSql database with the latest version of WordPress. I am not sure the issue is coming from there though (at least probably not all issues). What is this indexTest.php in your permalinks?

  3. Antonio Silva
    Member
    Posted 1 year ago #

    Thanks Chouby,

    We can connect WP with PostgreSql using pg4wp php setup that you configure prior WP installation.

    Indextest.php is just my temporary index file while I'm constructing my web site!! nothing more!!

    So my two main issues (and maybe they are related to each other) one I can't have two different themeFrontpage and second I can only see the menu for the default language.

    Could you tell me if http://www.grappler.tk/responsive/wp-admin/admin.php?page=theme_options&lang=fr is made with Polylang or another language plugin?? because if this is polylang, I don't have such presentation for Themesoptions

    thanks

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    The issue is probably coming from this indextest.php. I am curious to know how you make this work as 'index.php' is hardcoded in wp-includes/rewrite.php

    I don't know how you logged in to this site but of course I can't... On frontend, we can see what seems to be the qtranslate language switcher

  5. Antonio Silva
    Member
    Posted 1 year ago #

    Big thanks Chouby... that was it. I can't believe it was so simple!!

    As on how I did it, I just insert that URL in WordPress General settings

    I'm carrying that since the beginning!!

    Now back to work!! Case closed!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic