WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Menu point created by Buddypress cannot be deleted (6 posts)

  1. kbalia8
    Member
    Posted 2 years ago #

    Hi!

    I've just installed BuddyPress. My theme is comaptible with it, but after the installation in my customized menü a new (first) point appeared. This menu point was created by Buddypress (Community, - Activity, - Groups, - Forums). I cannot change the sequence and i can not delete this menu point.

    What can be the problem?

    Thanks,
    bálint

  2. @mercime
    Volunteer Moderator
    Posted 2 years ago #

    This menu point was created by Buddypress (Community, - Activity, - Groups, - Forums).

    We don't have anything like that in the BP Default theme. So that looks more like your custom theme issue than a BuddyPress one.

    If you change to bp-default, the main menu will default to wp_page_menu. However, since bp-default has custom menu support, you can change what links you want to show in your main menu ... something you might want to add in your custom theme
    -> http://buddypress.trac.wordpress.org/browser/tags/1.5.6/bp-themes/bp-default/header.php#L47
    -> http://buddypress.trac.wordpress.org/browser/tags/1.5.6/bp-themes/bp-default/functions.php#L79

  3. kbalia8
    Member
    Posted 2 years ago #

    Okay. but I have this theme in another site with buddypress too and there wasnt any problem like this.
    "you can change what links you want to show in your main menu" How can I do that?

    My theme is Custom Community.

  4. @mercime
    Volunteer Moderator
    Posted 2 years ago #

    but I have this theme in another site with buddypress too and there wasnt any problem like this

    Then only you can compare what's different between your two installations which have BuddyPress on Custom Community.
    - Check Appearance > Menus on both installs, same?
    - Check Other Configurations in Theme options page of both installs, same?
    - etc.

  5. kbalia8
    Member
    Posted 2 years ago #

    I checked everything, and everything is the same. The only difference could be the different sequences of steps.

    Because here I had the customized theme when I installed Buddypress and during the installation wizzard I chose the last option "Dont change the current theme" (or sth like that). On the other page I installed buddypress and then I chose this theme and customized it.

    Maybe in this site: if I could go back to the installation wizzard of buddypress I could chose another option under theme options. But i dont know how can I go back.

    Do you think this can be the prblem?

  6. kbalia8
    Member
    Posted 2 years ago #

    Just as you said it before the solution was in the theme options. Thank you for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic