WordPress.org

Ready to get started?Download WordPress

Forums

Menu out of place when compression turned ON in SuperCache! (3 posts)

  1. sammy123
    Member
    Posted 6 years ago #

    When compression is turned on in the latest version, the menu is all out of place...

  2. sammy123
    Member
    Posted 6 years ago #

    In accepted files box, it says:

    ";" class="code">>
    <label><input type="radio" name="cache_compression" value="0" checked=checked> Disabled</label>
    <p>Compression is disabled by default because some hosts have problems with compressed files. Switching this on and off clears the cache.</p>
    <div class="submit"><input type="submit" value="Update Compression »" /></div><input type="hidden" id="_wpnonce" name="_wpnonce" value="5db3476b9d" /><input type="hidden" name="_wp_http_referer" value="/wp-admin/options-general.php?page=wp-super-cache/wp-cache.php" /></form>
    </fieldset>

    <fieldset style='border: 1px solid #aaa' class="options">
    <legend>Mod Rewrite Rules</legend> <p>WP Super Cache has modified your /home/.josphina/brainblogger/blog/.htaccess file. Click the following link to see the lines added. If you have upgraded the plugin make sure these rules match. View mod_rewrite rules
    <div id='rewriterules' style='display: none;'>
    <p>

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{HTTP_COOKIE} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]
    
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{HTTP_COOKIE} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    
    </p>
    </div>
    </fieldset>
    <fieldset style='border: 1px solid #aaa' class="options">
    <legend>Expiry Time</legend><form name="wp_edit_max_time" action="/wp-admin/options-general.php?page=wp-super-cache/wp-cache.php" method="post"><label for="wp_max_time">Expire time:</label> <input type="text" size=6 name="wp_max_time" value="3600" /> seconds
    <label for="super_cache_max_time">Super Cache Expire time:</label> <input type="text" size=6 name="super_cache_max_time" value="21600" /> seconds<div class="submit"><input type="submit" value="Change expiration »" /></div><input type="hidden" id="_wpnonce" name="_wpnonce" value="5db3476b9d" /><input type="hidden" name="_wp_http_referer" value="/wp-admin/options-general.php?page=wp-super-cache/wp-cache.php" /></form>
    </fieldset>
    <fieldset style="border: 1px solid #aaa" class="options"><legend>Accepted filenames, rejected URIs</legend><p>Add here strings (not a filename) that forces a page not to be cached. For example, if your URLs include year and you dont want to cache last year posts, it's enough to specify the year, i.e. '/2004/'. WP-Cache will search if that string is part of the URI and if so, it will not cache that page.</p>
    <form name="wp_edit_rejected" action="/wp-admin/options-general.php?page=wp-super-cache/wp-cache.php" method="post"><label for="wp_rejected_uri">Rejected URIs</label><textarea name="wp_rejected_uri" cols="40" rows="4" style="width: 70%; font-size: 12px;" class="code">wp-.*.php
    index.php
    "

  3. sammy123
    Member
    Posted 6 years ago #

    And the cache does not clear...

Topic Closed

This topic has been closed to new replies.

About this Topic