WordPress.org

Ready to get started?Download WordPress

Forums

Menu links do not work (17 posts)

  1. Divinemsd
    Member
    Posted 1 year ago #

    I actually don't know which WP version is on server. Just installed it and it is asking to be updated to 3.4.2
    Just started building the site: http://www.libbyhanley.net/wordpress
    Set up all my pages using the wp custom menu feature. When I click on any of the menu items I get the 404 message.

    I know it isn't a theme issue because I have switched to several.

    On my permalink page I have this: If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.
    This is in the field: <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

  2. Divinemsd
    Member
    Posted 1 year ago #

    Oops not a 404 it is this: "The requested URL /wordpress/certifications/ was not found on this server."

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    You need to create an .htaccess file in your WordPress root folder (assuming there isn't one already), add that code block to the file and then upload it.

  4. Divinemsd
    Member
    Posted 1 year ago #

    Oops not a 404 it is this: "The requested URL /wordpress/certifications/ was not found on this server."

  5. Divinemsd
    Member
    Posted 1 year ago #

    OK thanks. will do that shortly

  6. Divinemsd
    Member
    Posted 1 year ago #

    Created the .htaccess file in GoLive, but it isn't visible as a file when saved nor will it upload it via FTP, in a folder.

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    No - you need to use a plain text editor.

  8. Divinemsd
    Member
    Posted 1 year ago #

    Did that also, still won't load via FTP

  9. Divinemsd
    Member
    Posted 1 year ago #

    OK I have the file up, but nothing has changed

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    Try resetting your permalinks again.

  11. Divinemsd
    Member
    Posted 1 year ago #

    it works now, but only with the default setting.

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    And what happens if you set up a custom permalink structure again? do you get the same message. Did you upload the .htaccess file to the correct folder(the one you installed WP into)? Did you upload the .htaccess file in ASCII format?

  13. Divinemsd
    Member
    Posted 1 year ago #

    Yes, same things happen with custom permalink structure.
    I installed in my root folder.
    If I name it .htaccess I can't save it period. Tried uploading it named "untitled" and it will load the file with no contents, but I can change the name on the server.
    I'm on a Mac if this makes a difference.
    Don't have a program that will save as ASCII, but can save as plain text, which I think is the same? I haven't seen ASCII in years!

  14. wpsecuritylock
    Member
    Posted 1 year ago #

    You have WordPress 3.4.1, so you're only one behind but you should update. It contains some bug fixes and security updates. That might help your menu problem too.

    You have your site installed in a folder called wordpress. Your .htaccess file should be inside public_html/wordpress.

    If you're connect via ftp and not sftp your host may not allow you to change "hidden" dot files.

    Try to delete the .htaccess file in the /wordpress directory and then save your custom permalinks again and see if that works.

  15. wpsecuritylock
    Member
    Posted 1 year ago #

    oops forgot to mention whenever save your permalinks it creates a new .htaccess file if it doesn't exist or re-writes to it if it does.

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    Don't have a program that will save as ASCII, but can save as plain text, which I think is the same?

    Yes it is. The upload has to be ASCII as opposed to binary in your FTP client.

  17. Divinemsd
    Member
    Posted 1 year ago #

    Thanks to both of you for your help. I can't get back to this until tomorrow, unless I get some time late afternoon. Will be back at it tomorrow.

Topic Closed

This topic has been closed to new replies.

About this Topic