WordPress.org

Ready to get started?Download WordPress

Forums

Menu Links add an extra "/" (6 posts)

  1. KinXen
    Member
    Posted 9 years ago #

    I did a quick search for this topic but nothing came up related to what I was specifically looking for.

    On my site, anytime I create a link to another part of the site, it adds an extra "/" between the link. For example when I create pages, the link may end something like "index.php/?page_id=3" or when I view commends it would look like "index.php/?p=1#comments" or maybe when I check out the archives, it would look like "index.php/?m=200505".

    It does this to all the links that link back to some other part of the site. I even checked Blog address (URI) in the options and it doesn't end with a "/".

    So does anyone know of a fix that doesn't add that extra "/" after the index.php?

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Where is your site ?

  3. KinXen
    Member
    Posted 9 years ago #

  4. darkcanuck
    Member
    Posted 9 years ago #

    What setting did you use for permalinks? (go to Options » Permalinks in the admin menu)
    If it shows /index.php/, clear the value and resave.

  5. KinXen
    Member
    Posted 9 years ago #

    It doesn't have anything in there, and if I do put /index.php or /index.php/ it still wont work, and all the links seem to change

  6. ceo
    Member
    Posted 9 years ago #

    I think part of the problem is stemming from the fact that you have the blog's url set with the index.php at the end.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags