WordPress.org

Ready to get started?Download WordPress

Forums

Admin Menu Editor
Menu Item Not Showing But Should (7 posts)

  1. thatryan
    Member
    Posted 5 months ago #

    I have purchased the Pro version.

    I am using User Role Editor Premium to create a custom role, inherited from Administrator.

    I cannot get Yoast Google Analytics plugin to show under "settings" even though the custom role created is selected inside Admin Menu Editor, and "permissions" for that page is 'edit_users' which is checked for that role as well.

    Is there some setting or something I am missing?

    http://wordpress.org/plugins/admin-menu-editor/

    Edit: Also, this is on a MultiSite setup. Curious, if I give a user "super admin" rights, does that override any menu items I hide with Admin Menu Editor?

    Thank you.

  2. Janis Elsts
    Member
    Plugin Author

    Posted 5 months ago #

    Some basic things to check:

    1. Find the Settings -> Google Analytics menu item in the menu editor and click the "Edit..." button next to the Permissions field.
    2. You should see "Permissions" pop-up with a list of roles. Is the custom role checked?
    3. Is there anything in the "extra capability" field? It should be empty by default.
    4. If everything checks out, click "Save Changes" (even if you didn't change anything).
    5. Make sure the menu is not completely hidden (no gray puzzle icon on the menu).

    Curious, if I give a user "super admin" rights, does that override any menu items I hide with Admin Menu Editor?

    It depends. As you may have noticed, the Pro version of Admin Menu Editor has a list of roles at the top of the editor, which also includes Super Admin. So normally giving someone "super admin" rights would let them access everything, but you can use AME to hide menu items even from the Super Admin. (Of course, they could get around that fairly easily by just uninstalling the plugin or manually deleting its database entries.)

  3. thatryan
    Member
    Posted 5 months ago #

    Thanks for getting back so quick.

    I have even set this user as an administrator to test and the analytics menu is still hidden. Not sure if I messed something up somehow, or it may be a bug with that plugin?

    To confirm, Yes, in the popup the custom role is checked, extra capability field is empty, and menu is not hidden.

    Thank you.

  4. thatryan
    Member
    Posted 5 months ago #

    Another test. I have this multisite setup on WPengine. And they have their own menu item that shows up on sites to control server stuff and login to WPengine. This shows up for super admins. I tried hiding it by adding the user:username to the extra capability field, but it appears to ignore it?

  5. Janis Elsts
    Member
    Plugin Author

    Posted 5 months ago #

    I have even set this user as an administrator to test and the analytics menu is still hidden. Not sure if I messed something up somehow, or it may be a bug with that plugin?

    To make sure it's not an AME configuration issue, try deactivating AME. Does the menu show up? Then reactivate AME, export your current menu configuration, load the default menu and save. Does it show up now?

    Another test. I have this multisite setup on WPengine. And they have their own menu item that shows up on sites to control server stuff and login to WPengine. This shows up for super admins. I tried hiding it by adding the user:username to the extra capability field, but it appears to ignore it?

    Sorry, I'm not sure if I'll be able to help with that one. For all I know, WPEngine might be running a modified version of WordPress that will always display that specific menu item.

    Still, here are two things you could try:

    • Just as a test, add the "user:username" extra capability to another menu item (e.g. Settings -> Discussion). Does it work as expected? If it does, WPEngine is probably doing something unusual with their own menu item that may prevent AME from hiding it.
    • Make a note of the WPEngine menu item URL. Then click the small "Settings" link next to the "Menu Editor Pro" page title and check the box that says "Enable the "Show/Hide" toolbar button". Go back to the menu editor, select the menu item and click the grey puzzle-piece icon in the toolbar, then save. Does the menu still show up? If not, can you access it by typing in the URL? (If something goes wrong, you can un-hide it with the same toolbar button.)
  6. thatryan
    Member
    Posted 5 months ago #

    Thanks for all the help and input, was able to get it working with crazy combinations of menu editor and roles :)

    Another question, is there a way to hide network menu items? For example there are some menus that only show up when logged into /network and not on sub sites.

    Thank you.

  7. Janis Elsts
    Member
    Plugin Author

    Posted 5 months ago #

    Another question, is there a way to hide network menu items? For example there are some menus that only show up when logged into /network and not on sub sites.

    No, unfortunately that is not possible. The plugin does not have the ability to edit the network admin menu.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.