WordPress.org

Ready to get started?Download WordPress

Forums

Menu is working fine on the home page but not on inside pages (7 posts)

  1. falconhead
    Member
    Posted 1 year ago #

    Hi,
    I was running my site on wordpress 3.3.1 earlier and I upgraded it to 3.5
    Everything is working just fine except for the menu.
    The menu works fine on the home page but does not work well on the inside pages.
    I checked the CSS output for the menu for the home page as well as the other pages, it seems that the CSS and the HTML code generated is a little different.

    http://www.liciuk.com/

    any help would be great.

    Thanks

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. falconhead
    Member
    Posted 1 year ago #

    I tried deactivating all the plugins but the problem persists.

    The menu works fine on the default twenty twelve theme. so this is a theme issue. but it was working just fine before the upgrade. So this is a theme issue. I'm cant get hold of the guy who designed the theme. so I guess I have to figure it out myself.

    I checked the header.php and the functions.php file and the theme had a menu class as well. but I could not figure out a fix.
    would you be kind enough to look into these files and guide me to fix the issue? how can I share the files with you?

    Thanks,

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    seems that the CSS and the HTML code generated is a little different.

    What did you identify as different?

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    Due to the level of work required to even begin to troubleshoot this kind of problem in a custom theme, perhaps you need to consider hiring someone to carry out the work for you?

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Gotta agree with that -- I looked at the site and yes, there are some major differences in the CSS code. There are also quite a number of mark-up errors on your pages (didn't check on CSS), so that's another potential source of problems -- may or may not be related to the menu issues, but it's always a good place to start.

    http://codex.wordpress.org/Validating_a_Website

  7. falconhead
    Member
    Posted 1 year ago #

    Yes I agree, this troubleshooting is not easy and you may be right that I might need to hire someone. Thanks guys for pointing me to some direction. hopefully I have this resolved soon.

Topic Closed

This topic has been closed to new replies.

About this Topic