WordPress.org

Ready to get started?Download WordPress

Forums

Hatch
Menu different on main page vs posts page (6 posts)

  1. gigeoxy
    Member
    Posted 3 months ago #

    Hello!
    Am trying to get the menu to display in the same place on the main page @ (gigiartdepartment.ca) versus on any given post page.

    Changing the relative position does not help. There's something higher up causing the difference between the pages. Maybe the "container" div? But I can't find that to modify in the Hatch css child theme.

    #menu-primary {
    	font-size: 2em;
    	width: 50%;
    	margin: 0 0 0 0;
    	position: relative;
    	top: -200px;
    	right: -476px;
    	clear:both;
    	z-index: 99;
    }

    Have tried a lot of things and spent a long time searching the help/support section, without any luck.

    I'm hoping you can help! Thank you :)

  2. saucer78
    Member
    Posted 3 months ago #

    The links you provided seem to point back to the support forums here...?

    Is this resolved? I found your site manually and the home menu and posts menu now seem to stay in the same place.

  3. gigeoxy
    Member
    Posted 3 months ago #

    Hi saucer78

    I tried to attack the problem from another angle, setting the position of the menu as absolute, which is not an ideal solution because i can't get the other elements to flow around it nicely. So the problem still stands. If you're around I can change the position back to relative...

    Thanks in advance!
    Gigi

    PS using Chrome, and mobile site too (I test it by shrinking the Chrome window)

  4. gigeoxy
    Member
    Posted 3 months ago #

    I don't know why those links would link back to the support forums. I definitely input my site links.

    main: gigiartdepartment.ca
    "post page": gigiartdepartment.ca/contact

  5. saucer78
    Member
    Posted 3 months ago #

    Well I'm still very new but have messed with my menu settings, so I thought I'd try to help out to give something back to this great community.

    However, comparing the code again, I'm probably in over my head - my custom css looks pretty much the same as yours and my menu works fine. Looking at your site right now, your header logo and menu are all the way at the top of the page. Do you need to add an upper margin or some padding? I'm having fun starting to understand things while inspecting elements, but can't really tell what's going on. Sorry, wish I could help!

    Play with the margins though, if you haven't already...

    margin: top, right, bottom, left;

  6. gigeoxy
    Member
    Posted 3 months ago #

    Still haven't figured out why the menu displays differently on the main page versus post pages. Frustrating! Thanks for your input though!

Reply

You must log in to post.

About this Theme

About this Topic