WordPress.org

Ready to get started?Download WordPress

Forums

Menu buttons point to wrong category (15 posts)

  1. Ken Soszka
    Member
    Posted 3 years ago #

    Hi, I have a couple of menu links that are pointing to a different category than what I set them up for in Appearance\Menus. Specifically, at http://www.FoodAndDrinkTips.com the Drink Tips menu button links to the Healthy Recipes category, and the Kitchen Gadgets menu button links to the Quick Recipes category. I have tried deleting and recreating the button, no luck.

    I can't say for sure, but this may have happened after updating WP to 3.03 earlier this evening. I am using the Arras theme, and have posted on their forum as well.

    Has anyone experienced this before? I am supposed to turn this site over to a client that I built it for, tonight.

    Thanks in Advance!

  2. Curtiss Grymala
    Member
    Posted 3 years ago #

    Have you checked the menu configuration to make sure that it's still correct? It looks like Drink Recipes and Kitchen Gadgets are both pointing to the wrong places, but I obviously can't tell just from looking at your page whether that's a configuration problem or a code problem.

  3. Ken Soszka
    Member
    Posted 3 years ago #

    Hi, first let me say that in my original post I made a mistake, it is the Drink Recipes button that is pointing to the Healthy Recipes category, not the Drink Tips button. I will correct the post.

    That being said, yes the config is correct. I even deleted the incorrect menu items from the menu, and recreated them. Thanks

  4. Curtiss Grymala
    Member
    Posted 3 years ago #

    Can you try switching over to the Twenty-Ten theme temporarily and see if that fixes the issue? If so, then it's definitely an issue with the way your Arras theme is outputting the menu somehow. If it doesn't fix the issue, then it's most likely not a theme issue.

  5. artbycrunk
    Member
    Posted 3 years ago #

    it would be helpfull to get a screenshot of the Appearance\Menus settings that you are using for the Drink Recipes button

  6. Ken Soszka
    Member
    Posted 3 years ago #

    It is switched to Twenty-Ten now, and the menu is not even visible.

    art, I will post a screenshot.

  7. Ken Soszka
    Member
    Posted 3 years ago #

    It shows in twenty-ten now - had to set it.

  8. Ken Soszka
    Member
    Posted 3 years ago #

    Here is a screenshot of the menu config. If I hover over the link by the green arrow, the correct path shows in the IE status bar.

    http://www.foodanddrinktips.com/images/menu-issue.jpg

  9. artbycrunk
    Member
    Posted 3 years ago #

    yes (Twenty10) you will need to set it as your Primary Navigation .. awaiting that screenshot :)

  10. artbycrunk
    Member
    Posted 3 years ago #

    lol.. posted at the same time that you replied :).. wait will check and get back to you..

  11. artbycrunk
    Member
    Posted 3 years ago #

    hmmm.. this is a strange error indeed.. which version of wordpress are you on..?
    i can acess http://www.foodanddrinktips.com/category/drink-recipes
    directly and seems to be fine..
    u seem a little frustrated.. im sorry but i dont have a solution right now, but ill try to figure out some thing..
    for a temporary solution i would suggest using the direct link to the catergory as a custom button..

  12. Ken Soszka
    Member
    Posted 3 years ago #

    WP version 3.0.3

  13. Curtiss Grymala
    Member
    Posted 3 years ago #

    I agree with artbycrunk's temporary solution.

    I wonder if there's some sort of weird bug in the menu procedures for WP 3.0.3 when it comes to categories. I'll have to do some investigation (I use WP mostly as a CMS, not a blogging platform, so I haven't used categories in the custom menus).

  14. artbycrunk
    Member
    Posted 3 years ago #

    its not a bug.. cause i tried in on my 3.03 installation and tried all sorts of ways to break it.. but it doesnt give any problems at my end... im still trying.. :P

  15. Ken Soszka
    Member
    Posted 3 years ago #

    Ok thanks to you both! I build lots of sites with this same setup, so I will post back here and let you know if it happens on my next site or not. Anything more that you figure out is appreciated too. -Ken

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags