WordPress.org

Ready to get started?Download WordPress

Forums

P2
Mentions links "Not Found" in P2 (7 posts)

  1. Tevya
    Member
    Posted 2 years ago #

    Hi all. A fresh install of P2 is working very well on WP 3.3. But with one exception: the mentions links (@username) don't seem to work. Clicking them takes you to http://sitename.com/mentions/username but it just gives the default:

    Not Found
    Apologies, but the page you requested could not be found. Perhaps searching will help.

    page in the P2 theme.

    Any ideas?

    http://wordpress.org/extend/themes/p2/

  2. Doud8ou
    Member
    Posted 2 years ago #

    Same problem for me !
    Some help ?

  3. keeperbay
    Member
    Posted 2 years ago #

    Same here and my theme is modified I can't update the theme, I need an actual fix.
    My entire blog is centered around this theme and the way it posts from the front. I need that to work.

  4. mobilemike
    Member
    Posted 2 years ago #

    Same problem here. I'm running on Windows, not sure if that's relevant.

    Other taxonomies, like categories or tag work, so I don't think it's something global broken with the URL parser.

  5. mobilemike
    Member
    Posted 2 years ago #

    I've gotten a bit further with this. It seems like registration of rewrite rules from the taxonomy are somewhat flakey. If you touch the permalink structure after installing P2, mentions will vanish.

    On trick seems to be simply deleting and reinstalling the theme, which must force a registration of the taxonomy. Alternatively, this seems to work, but YMMV:

    Open the theme editor and bring up mentions.php
    Make a change to the file (add something to one of the comments)
    Update the file
    Go to Settings -> Permalinks.
    Don't change anything, just click on Save Changes to force a rebuild.

    This last part comes from the codex on register_taxonomy: http://codex.wordpress.org/Function_Reference/register_taxonomy#Arguments
    Look at the note under the rewrite arg.

  6. Tevya
    Member
    Posted 2 years ago #

    I did the edit mentions.php and update permalinks. Worked great! Thanks.

  7. Michael Fields
    Themer
    Posted 2 years ago #

    I spotted this issue while making some updates to P2 last week. It will be fixd in the next version of the theme. Thanks for reporting!

    Quick Tip: To flush your permalink settings, all you need to do is visit Settings → Permalinks; there is no need to refresh :)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags