WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Memory hogging? (4 posts)

  1. Carlos Mundi
    Member
    Posted 4 years ago #

    I am a total newbie. I consider my first attempt to install WP3 to be a failure. Out of the box, I have timeouts, partial page renderings and connection drops on a server which dishes several other (non-WP) sites with no problem.

    I am having this problem wherein wp-admin.php appears to be trying to hog 256MB despite the fact that php.ini limits it to 64MB (and phpinfo() independently confirms this).

    This seems like a really basic installation problem. So I imagine I did something very naive. Any help is appreciated. Usually a do really specialized apps. I have someone who just needs a blog, so I figured WP would be the way to go. Six hours later... :)

    Thanks,
    Carlos

  2. WordPress 3.0 automatically attempts to increase the memory limit to 256mb if necessary when upgrading or installing plugins/themes. This shouldn't be causing any issues, but you might want to try manually boosting PHP's memory allocation via one of these methods:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    memory_limit = 256M ; Maximum amount of memory a script may consume (64MB)
    
    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 256M
    
    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '256M');
    
    4. Talk to your host.
  3. Carlos Mundi
    Member
    Posted 4 years ago #

    Thanks, folks. I'm using the default 2010 theme, actually release 1.1 of the 2010 theme. Zero customization. Zero plugins (ok, I tried band removed supercache). Added one comment. Just about every page access -- including landing on the homepage -- is trying to grab 256MB on my 360MB VPS. Massive disk thrash. Not cool.

    The whole point is, I have other things I need to do, and a turnkey CMS grinding a system out of the box is not in the plan.

    If you've read the other thread, you know that I've done and verified all the usual PHP memory_limit stuff. I'm quite familiar with that. And although not mentioned in the other thread, I'm using WP_MEMORY_LIMIT in wp-config.php and -- surprise! -- even when I set this to a lower number to match the php.ini reported by phpinfo() I find in my server log that WP still tries to grab 256MB.

    I had to stop using Drupal because it became such a PHP hog with only a few modules enabled. Someone suggested that I try WP because I was told it has a smaller memory footprint (at least for my simple needs), but that has not been my initial experience.

    Is there perhaps a way to strip WP down to a minimal core which requires less peak memory? I still suspect that I have somehow malconfigured WP which is making it want so much memory. I'd be happy to report some metrics if I knew where to look. I'm open to learning that I've done something stupid.

    Thanks,
    Carlos

  4. Carlos Mundi
    Member
    Posted 4 years ago #

    Ok, problem appears solved. Details over here. Short version: I did not increase my swap when I got more RAM. Silly me.

    Thanks,
    Carlos

Topic Closed

This topic has been closed to new replies.

About this Topic