WordPress.org

Ready to get started?Download WordPress

Forums

Memory exhausted error in admin panel after upgrade to 2.8 (67 posts)

  1. cleoni
    Member
    Posted 5 years ago #

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home2/user1/public_html/fantasy/wp-includes/class-simplepie.php on line 5353

    After upgrading to 2.8 I have this error in the Incoming Links widget in the main admin board.

    I could not remove the widget by clicking on the Screen settings tab as it produces no effect.

  2. C. Michael Mette
    Member
    Posted 5 years ago #

    I have the same error message (after upgrading to 2.8) dependig on how many plugins I activate in different places in the dashboard.

    For example in "Newest Draft":
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 10920 bytes) in C:\xampp\htdocs\websites\abzwordpress\wp-includes\query.php on line 2512

    It seems to change with the number of plugins I activate.

  3. digitalfaber
    Member
    Posted 5 years ago #

    Same poblem here.
    This is the message:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2348617 bytes) in /home4/guardib6/public_html/wp-includes/http.php on line 1033

  4. andrewtrench
    Member
    Posted 5 years ago #

    Follow the instructions here I had exactly the same problem as you guys and this sorted it out. I increased memory to 128M in the steps outlined at this link.

  5. andrewtrench
    Member
    Posted 5 years ago #

    To add to this.there is already a php.ini in wp-includes. simply open it and look for the memory reference and change it to the size you want

  6. MichaelH
    Member
    Posted 5 years ago #

    To add to this.there is already a php.ini in wp-includes

    That php.ini would have been put there by you or your host.

  7. jefblog
    Member
    Posted 5 years ago #

    exactly the same problem !
    after upgrading 2.8:
    in the the Incoming Links :

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 368640 bytes) in /mnt/110/sdb/1/d/jef/wordpress/wp-includes/class-simplepie.php on line 9575

    And the RSS don't work now!

  8. elking10
    Member
    Posted 5 years ago #

    the same problem here, but the error in "plugin" widget?!

  9. Nnyan
    Member
    Posted 5 years ago #

    Following the link posted by andrewtrench I added this line to my wp-includes/cache.php file (right after the <?php tag: )

    ini_set('memory_limit','64M'); // set memory to prevent fatal errors

    Why 64MB? Well if you look at your error you will get a memory size in bytes. The 33554432 in the error told me 32MB was not enough so I bumped it up to 64 and my errors in the dashboard went away. I did not have to do the other two steps.

  10. Gestroud
    Member
    Posted 5 years ago #

    You could also add this line to your wp-config.php

    define('WP_MEMORY_LIMIT', '64M');

    This way you won't have to constantly make the fix again whenever you upgrade WordPress.

  11. Nnyan
    Member
    Posted 5 years ago #

    Good to know gestroud!

  12. jeffaka
    Member
    Posted 5 years ago #

    Download Monitor was causing this error for me. Deleting it fixed it (though it also destroyed all downloads on the site...)

    [Plugin: WordPress Download Monitor] Breaks WP 2.8

  13. C. Michael Mette
    Member
    Posted 5 years ago #

    @gestroud

    Thanks - it seems your tip defining more memory in the wp-config.php solved the problem in my installation.

  14. digitalfaber
    Member
    Posted 5 years ago #

    @gestroud: great tip!
    Thanks a lot ;)

  15. NienOnline
    Member
    Posted 5 years ago #

    I tried all of the options mentioned above, but it solves nothing for me. :-(

  16. MichaelH
    Member
    Posted 5 years ago #

    @NienOnline - assuming you've deactivated all plugins, the try one of these methods for increasing the amount of memory a PHP script may consume

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');

    4. Talk to your host.

    Related:
    How to deactivate all plugins when not able to access the administrative menus?

  17. NienOnline
    Member
    Posted 5 years ago #

    Thanks Michael,

    I tried all, except number 4...

  18. elking10
    Member
    Posted 5 years ago #

    Who still face the problem, see this page..
    http://wordpress.org/support/topic/194370?replies=18

    For me the problem was causing from "ToDo mini form plugin", after deactivated it every thing be fine.

    Thanks too MichaelH for help.

  19. Tmhrtwg
    Member
    Posted 5 years ago #

    I tried all of the above solutions, but my error remains, unfortunately..

    Here's my error, maybe it gives someone an idea of how fixing it :)

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 311296 bytes) in (...)wp-includes/class-simplepie.php on line 4128

    Is there another way to fix this? Or is it better for me to roll back to my 'old' version of wordpress (2.7.1)? The webhost won't cooperate, and I can't reach my php.ini because of them :(

  20. jefblog
    Member
    Posted 5 years ago #

    It was the plug-in "Contact7" which do this error in my WordPress Dashboard. Then I stop this plug in and the Dashboad works correctly . but i have now a new error message :

    Fatal error: cannot yet handle MBCS in html_entity_decode()! in /mnt/110/sdb/1/d/jef/wordpress/wp-includes/default-widgets.php on line 801
    in the "WordPress Development Blog"

  21. sfranchi
    Member
    Posted 5 years ago #

    Same stuff here with other plugins, but increasing the memory in .htaccess solved the problem for me.

  22. ucero
    Member
    Posted 5 years ago #

    I had the same problem and I solved it by method 2 (2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M). Thanks MichaelH!

  23. martin_62
    Member
    Posted 5 years ago #

    I had to deactivate Nextgen Gallery plugin. The other methods didn't work for me. My php.ini, which I can't reach, has a limit of 32 M. I think, it can't be overridden?

  24. cleoni
    Member
    Posted 5 years ago #

    It seems that version 2.8 is more memory-hungry than previous versions.

    The problem seems to disappear if you disable more and more plugins.

    The memory exhausted error pops up in other installations of mine, never saw this problem before the upgrade.

    I suggest checking closely memory consumption on next releases, and putting a limit on it. Not all hosting environments allow users to rise memory limits.

    Cheers

  25. Arlindo Pinto
    Member
    Posted 5 years ago #

    Hi!
    Have the some problem in Admin Panel, Uploading photos, update plugins etc.
    My host dont upgrade memory limit, so what to do?
    Damn.
    Cheers from Portugal

  26. w1n78
    Member
    Posted 5 years ago #

    deactivating some of my plugins also fixed the problem. no biggie, i wasn't really using those ones anyway.

  27. MichaelH
    Member
    Posted 5 years ago #

    Could be this:
    https://core.trac.wordpress.org/ticket/10147

    If you are willing you can download the 2.8.1 beta that has that fix at:
    http://wordpress.org/nightly-builds/wordpress-2.8-latest.zip

  28. mcbalz
    Member
    Posted 5 years ago #

    I had this problem and, through my inept tinkering, ended up actually completely destroying both of my new 2.8 blogs. Turned out it was a php memory limit set by the service provider and NOT customizable by me. The 8 MB limit my provider gives is not enough to run WP 2.8.

    I was running only ONE plug-in (Akismet), and I had small databases (less than 2 MB each) but I still couldn't run WP 2.8 on account.

    I think this is a major bug that the WP development community needs to fix. I want to use WP... it is clearly the best... but at present I just can't do it. Also, after porting over to my self-installed WP blog, I deleted my old blogger blog, and after this fiasco, all that I have left is the MySQL database. My old blog is now totally off line.

    I'm feeling kinda bitter about this issue.

  29. MichaelH
    Member
    Posted 5 years ago #

    all that I have left is the MySQL database

    mcbalz
    Backup that database, and consider moving your domain to a new host. If a new host is not an option, then restore your 2.7.1 database and 2.7.1 files.

  30. mcbalz
    Member
    Posted 5 years ago #

    Michael, how can I get the database information into a WP installation?

Topic Closed

This topic has been closed to new replies.

About this Topic