WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Memcache disabled on server and cannot modify settings (2 posts)

  1. Russ
    Member
    Posted 1 year ago #

    When setting up W3 Total Cache, I import a settings file, however I have run into a problem.

    Previously, we had memcache on our server, but that has been removed. However, the memcache setting is in the import file. After importing the settings, everything blows up. I can manually remove the W3TC files to get back into the admin panel, but when I try to reinstall the plugin, I get the following:

    Plugin could not be activated because it triggered a fatal error.
    Fatal error: Class 'Memcache' not found in /.../Memcached.php on line 38

    So I am thinking that this setting is in the database somewhere and I need to remove that. Any ideas on how to go about that?

    Once I get this addressed, I will change the setting to Disk Enhanced and then export those settings.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. relequestual
    Member
    Posted 5 months ago #

    If anyone comes across this problem like I did, you'll find the config file to chnage in wp-content/cache/config/master.php

    In there, search for .engine, and some of those items will be set to memecached. Change them to 'file', and you should then be able to access your site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags