WordPress.org

Ready to get started?Download WordPress

Forums

Members Only - redirect to Dashboard (7 posts)

  1. Hjald
    Member
    Posted 6 years ago #

    Hi. New at this forum.

    I have installed the plugin 'Members-Only' - succesfully. It works.

    But users there is correctly logged in - is redirected to the dashboard.

    I want to redirect them to the blog. How do I do that.

    The users that I will allow at my blog - will not nessesary turn around the dashboard before going to the blog. My blog is in the root of my homepage - so I just want to redirect them to ex: wwww.xxxxxx.net

    I tried to install 'Role Manager' and 'Weasels login direct' without any succes.

    Hope that someone can help. Thanks.

  2. hami
    Member
    Posted 6 years ago #

    By default, Members Only will redirect the user to the page they requested - if that's the dashboard that's where they will go.

    There is option to turn this option off called 'Return User'. Try unchecking that and see if it works?

    / Hami

  3. dhdesign
    Member
    Posted 6 years ago #

    Hami -

    I am having the same issue. I have Members Only 0.6.5 installed, along with the latest versions of Register Plus and WP User Moderation in order to control access to my site. Whenever anyone logs in, they are redirected to their profile page (I've hidden the dashboard from them) and have to click the Visit Site link in order to get to the website.

    On the settings page for Members Only, I have the following:

    Redirect To: Login Page
    Return User: unchecked
    Redirection Page: http://www.mydomain.tld/index.php

    WordPress is installed in the root folder, and I am using fancy permalinks.

    Any ideas?

    Thanks in advance!

  4. dhdesign
    Member
    Posted 6 years ago #

    Okay, I changed a couple of settings. First, I resaved my permalink structure, then I went to the Members Only settings page and checked the box next to Return User. I left the other settings the same.

    When I use the link http://www.domain.tld/ to access the site, I am redirected to the login page with the url http://www.domain.tld/wp-login.php?redirect_to=/ (notice there is no index.php in that url). I log in, and am now sent to the main page of the site, not the profile page.

    I'll add a separate link so people can update their profiles if they need to.

    I think my issue may be resolved now (*crossing fingers*), but will let you know if it crops up again.

  5. dhdesign
    Member
    Posted 6 years ago #

    Sorry for so many posts, but I've done a bit more testing, and here are the results, using the settings in my previous post:

    User goes to http://www.mydomain.tld/ to access the site, and is redirected to the login page with the url http://www.mydomain.tld/wp-login.php?redirect_to=/. They log in, and are sent to the main page of the site.

    Same user logs out from a link on the site (http://www.mydomain.tld/wp-login.php?action=logout)and is sent back to the login page with a url of http://www.mydomain.tld/wp-login.php?loggedout=true. They then decide to log back in using the form on that page, and then they are sent to their profile page, not the site. They have to click the Visit Site link in order to get to the website under this scenario.

    Not sure what, if anything, can be done, but all suggestions are welcome. :)

  6. bestfoot
    Member
    Posted 6 years ago #

    I have the same problem.

    I am at http://domain.com/members/

    If I log on, I am at the dashboard ...

    Any ideas?

    I have redirect set to http://domain.com/members/index.php, but that doesn't seem to have any impact. All users are "authors".

  7. crobs808
    Member
    Posted 6 years ago #

    same issue....I have my worpress site installed at domain.com/blog, so i have domain.com auto forward to the /blog directory, and since i have members-only installed it shows the login (good that is what I want)

    then, wen a user logs in, it goes to the dashboard, even though in my members-only settings, i have it set to "specific page" and in the box types in "index.php" so it should go to domain.com/blog/index.php...but it is not, its going to wp-admin. Basically, the members-only plugin is acting as the last page that the user was on, even though it should use the page before that...so it always forces the user back to wp-admin, no matter hat you set in the setting sfor "Specific site"

    so, to HAMI - the author, please redirect to the initial site, not the members-only forced wp-admin site....

    Your "specific page" option is broken, does not function how it should, since you go to the dashboard NO MATTER WHAT you set as your plugin settings.

Topic Closed

This topic has been closed to new replies.

About this Topic