WordPress.org

Ready to get started?Download WordPress

Forums

WP-Members
Members do not receive any email with password (8 posts)

  1. ProfC
    Member
    Posted 7 months ago #

    Hi,
    since I installed last update 2.8.10, new members registered on the blog and approved manually by me do not receive confirmation email with password as it was before.
    What can I do? It's very important for me to fix this problem soon.
    Many thanks,
    Gabriele

    http://wordpress.org/plugins/wp-members/

  2. ProfC
    Member
    Posted 7 months ago #

    I did some more tests. If I reset password, it works fine, I can receive quickly a new email with new password. So... I cannot figure out why the only email I cannot receive is the confirmation email with the first password to log in.
    Please, try to help me.
    Many thanks
    Gabriele

  3. ProfC
    Member
    Posted 7 months ago #

    I did one more test, as you suggest on the faq. I tried to register new user form WP Users > Add New and checking "Send this password to the new user by email", but the new user doesn't receive any email. So, I cannot receive email with new password both from WP admin panel and from WP-member form, but I can receive all the other emails (if you reset password, when you register etc). Why?

  4. ProfC
    Member
    Posted 7 months ago #

    New test: I tried to send some email by "email users" plugin, and it doesn't work as well.
    I forgot to tell you that I use a Gmail account. Everything worked fine until some weeks ago

  5. Chad Butler
    Member
    Plugin Author

    Posted 7 months ago #

    It sounds like you've got some problems with wp_mail. I have some information on wp_mail troubleshooting over on my personal blog.

  6. ProfC
    Member
    Posted 7 months ago #

    I tried a test with mailtest.php, but I got this error

    Parse error: syntax error, unexpected T_NS_SEPARATOR in /home/... etc

    ??

  7. Chad Butler
    Member
    Plugin Author

    Posted 7 months ago #

    Well, you didn't include the file and line number of the error, nor what is at that line, so I have to guess.

    The error message indicates that you have a "namespace separator" that PHP is not expecting. That would be the \ character. So if the error message corresponds with the script file, it would indicate that you did not copy/paste the script as shown.

    If you typed anything in yourself and reversed the php comment indicator (i.e. \\ instead of //), that would cause such an error.

  8. ProfC
    Member
    Posted 6 months ago #

    Dear Chard, I just copied the script from your web page and changed the email address. May I send you the script somewhere to check it?
    Many thanks,
    Gabriele

Reply

You must log in to post.

About this Plugin

About this Topic