WordPress.org

Ready to get started?Download WordPress

Forums

Media/Image with caption (ALT text) causing error on posts. (4 posts)

  1. DRGDC
    Member
    Posted 6 years ago #

    I'm running WordPress 2.6.

    When I create a new post and upload and include an image with a caption specified I get an error at the top of my posts right above the post body.

    Warning: Compilation failed: characters with values > 255 are not yet supported in classes at offset 16 in /vservers/radianne/htdocs/wp-includes/shortcodes.php on line 213

    The error only occurs when the image has a caption used for the ALT attribute of the IMG tag.

    This was difficult to track down because there are bugs in updating the caption for images in the media library.

    I enter a caption upon upload of a photo and include the image in my post. I get the error. Next I edit the photo properties and delete the caption, but the error remains because the ALT attribute is still showing the caption I deleted.

    I upload an image without a caption (no error) and then edit the image to add a caption. There is no error because the ALT attribute is still blank.

  2. Anonymous
    Unregistered
    Posted 6 years ago #

    I am experiencing this problem too. I did some searching on google and people using Drupal experience this if their version of PHP is below 4.3.3, as mine is. What version of PHP are you using?

  3. Anonymous
    Unregistered
    Posted 6 years ago #

    I just upgraded my server to php 4.4.8 and the error has gone away.

  4. DRGDC
    Member
    Posted 5 years ago #

    Thanks to WP-ServerInfo I see I am running on PHP 4.3.2. I'll put a ticket in with my hosting provider for an upgrade.

    FYI; Display your host's server PHP and MYSQL information (integrated into WordPress Admin Style) on your WordPress dashboard.
    http://lesterchan.net/portfolio/programming/php/#wp-serverinfo

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.