WordPress.org

Ready to get started?Download WordPress

Forums

media-upload.php error (13 posts)

  1. Ezcali
    Member
    Posted 5 years ago #

    I get an error while trying to use images from my Nextgen-gallery in the posts. The error accured after i upgraded to the latest WordPress edition.

    The Error:
    I click on "write" then the "add photo" quicktag. Then I click the NextGEN-gallery tab, select an image and try to add it to my post. I get a white screen in a popup window and a script-error saying:

    Line: 4
    Char: 1
    Error: Permission Denied
    Code: 0
    URL: http://www.../wp-admin/media-upload.php?type=image&tab=nextgen&post id=-122295830

    This is the only error I get but it is frustrating because Im unable to add images to my posts.

    I have tried several solutions I found on other forums but nothing seems to work.

    Hope anyone can help.

    Jesper

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

  3. Ezcali
    Member
    Posted 5 years ago #

    I tried step 6 but it didnt work.

    The funny thing is that I have the excactly same website on a different webhotel and the image issue works fine there but not on this webhotel?

  4. danapellerin
    Member
    Posted 5 years ago #

    I'm having the exact same issue. And my problem manifests itself differently depending on the account. For instance, the Admin account works fine, a second account throws the error you describe, and a third account throws no errors, but freezes at the same point (when clicking the "insert into image" button).

    All of these accounts are being tested on my workstation under both IE7 and FireFox3. I've tried everything in the support post above but nothing works.

    Frustrating because we can't roll this out until this is fixed, yet I see posts going back 6 months on this same issue with no resolution.

  5. websitehelper
    Member
    Posted 5 years ago #

    I also have this problem. Have tried everything recommended across multiple forums, including here. I even upgraded to latest version (asof today) and no improvement.

    I am using IE7 with the media upload "user browser upload" option (not flash). It does upload the file but when I try to insert into post, it gives me the white screen and the permission denied error on line 4 as stated above in previous post.

    My URL's root is actually at /var/www/html/ and I am wondering if some code might not be handling the pathing properly. I don't have to use this in any of my relative addressing, but I guess it could be possible that this could cause a problem. ???

  6. websitehelper
    Member
    Posted 5 years ago #

    Helloooo. Is anyone monitoring these posts?

    More information on this problem. The "media upload" feature has never worked and I am determined to figure out why, since I learned that it is working on another WordPress blog I manage that is hosted on a different server than the one giving me the problem -- so this tells me that it is not the code or how I configure it. It is something server-specific.

    The error I get when using the "browser upload" feature (not the Flash, which is another story) is "permission denied" for the file wp-admin/media-upload.php.

    I think it is a pathing problem. I am seeing the following path for the photos that are displayed now:

    /var/www/html/blog/wordpress/wp-content/uploads/2008/11/bkgd-grid.jpg

    but the default folder for my media uploads is "wp-content/uploads".

    Has anyone gotten this to work on WestHost servers and what are your settings for the default path?

  7. bradyjfrey
    Member
    Posted 5 years ago #

    Never tested westhost, but I wanted to note that you should probably avoid, even version 7, IE like the plague. There have always been intermitten issues with IE in just about any high end web software (if not an issue, for sure a downgraded experience us developers create on purpose to compensate for it's weaknesses), have you tried using Firefox or Opera or Safari?

    If you're indeed having issues with relative path, do you have any experience with mysql? If so, you could command line in or use PHPMyAdmin on your server and go through the images paths to see where everything is pointing too. This is not an easy thing to do for a novice user, you maybe best suited to ask a friend with experience in this - someone you trust on your server.

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Sigh.

    All known image uploader issues and solutions to them are listed here: http://wordpress.org/support/topic/164999

    If you have tried everything there, and it did not fix it, then it probably can't be fixed. Really. I do update that listing from time to time, and I have yet to encounter a site that was not fixed by those solutions.

    So posting here asking for help isn't going to get you any beyond what is in that post. Honestly. All we can really say is "do what's there" and "did you really do what it said there?" and "double-check that you did what it said correctly". Because if you follow all those instructions, then your site would most likely be working correctly.

    And a "permission denied" error is almost invariably a problem with mod_security. Step 6. Like I said before.

  9. websitehelper
    Member
    Posted 5 years ago #

    bradyjfrey: No change when I use Mozilla/Firefox. Note that I can upload images fine. I can see them in the /uploads/2008/12 folder on the server. It is only when I try to "insert into post" that I get the blank screen. I am using the "browser upload" option (not the Flash). Would the version of Flash that I use matter for this option? I noticed that something somewhere said that the Flash version only worked if you used the older version 9.

    Yes, I know how to use phpMyAdmin. What do you want me to check? In the wp-options table, the uploads_path is "wp-content/uploads". When I try to change the "root" upload path, it does not change anything in the path for the images associated with individual posts - these seem to be "preserved" with the individual post. Here is the path I am seeing for an image filethat got uploaded, but not inserted:

    http://www.CircleOfFood.com/blog/wordpress/var/www/html/blog/wordpress/wp-content/uploads/avatar-48x48.gif

    The "/var/www/html" should not be there (so this would explain the bad relative path that would give me a permission problem), but how did it get there if my uploads_path is "wp-content/uploads"??

    What I am worried about is that the WordPress code may have a "/" in front of some path built from the database instead of using "../" for making it relative.

    Otto42: Yes, I really did try everything in the list. I am at the most current version, I created your .htaccess file -- nothing helped. I am not the only person having this trouble if you do a search on "wordpress media upload permission denied" problems.

  10. websitehelper
    Member
    Posted 5 years ago #

    Clarification: I got the path to look correct when I look at image attachment records in the wp-posts table ("guid" field), as follows:

    http://www.circleoffood.com/blog/wordpress/wp-content/uploads/2008/12/fat-bulldog.jpg

    but I still get the white screen on the "insert into post"

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    The "/var/www/html" should not be there (so this would explain the bad relative path that would give me a permission problem), but how did it get there if my uploads_path is "wp-content/uploads"??

    The uploads_path controls where the file goes, but the other uploads option controls what the URL looks like. See the Settings->Misc screen.

    When I try to change the "root" upload path, it does not change anything in the path for the images associated with individual posts - these seem to be "preserved" with the individual post.

    No, they're preserved for the individual attachment. Changing the upload path doesn't magically make your files actually move around or something. Changing the upload path causes new files to go to that new location. Old files stay where they were.

    What I am worried about is that the WordPress code may have a "/" in front of some path built from the database instead of using "../" for making it relative.

    Relative links won't work, because the URL is not a fixed entity, it changes on single pages, on category archives, on the main page, etc. That's what the Permalinks do, after all.

    WordPress uses absolute links at all times, in all places.

    It is only when I try to "insert into post" that I get the blank screen.

    Make sure that you're not getting any javascript errors in the Error Console. If so, make sure that all the javascript is uploaded to your site correctly, that it has the correct permissions, etc. Inserting the image link into the post is basically a pure javascript operation.

  12. websitehelper
    Member
    Posted 5 years ago #

    How do I check for javascript errors in the Error Console?

    When I get the blank screen in IE 7, the error message flagged in the status bar is:

    Line: 4
    char: 1
    Error: Permission denied
    URL: http://www.circleoffood.com/blog/wordpress/wp-admin/media-upload.php?post_id-1229034506&type=image&flash=0

    Wouldn't the error be in the media-upload.php file, or more specifically, one of the includes on line 4 of that file?

  13. mperry8304
    Member
    Posted 5 years ago #

    Sorry Otto42, the answer to this problem for me was not in the page that you listed. Instead the answer was on this page:

    http://wordpress.org/support/topic/197027/page/2?replies=39

    In the general settings for the blog I'd been creative and put some capital letters in the URL. Once I changed everything to lower case the "permission denied" errors went away and I can now upload photos.

Topic Closed

This topic has been closed to new replies.

About this Topic