WordPress.org

Ready to get started?Download WordPress

Forums

Media Uploader problem not solved by Sticky ^ (7 posts)

  1. Tate-Ramingham
    Member
    Posted 4 years ago #

    Hi,

    I have been experiencing difficulties with uploading photos through the Media uploader. All the image files I have tried are relatively small, less than 40kb and less than 400x400px. I have tried all the remedies outlined in the sticky topic above (http://wordpress.org/support/topic/164999?replies=1). I replaced all the WP files, I've deactived/reactived plugins, changed the folder for uploads to be stored and then changed it back to the default, and cleared my temp-files/cache between every attempt (I'm using Firefox, not IE BTW). All with no luck.

    When using the flash uploader I get the following error message: Missing a temporary folder.

    When using the browser uploader I get the following error message: Error saving media attachment.

    I can upload files manually via ftp but that is time consuming and unfeasible for the other authors who will be publishing on the blog.

    Could it be an issue with read/write permissions on the server?

    Any input or suggestions would be greatly appreciated. Thanks!

  2. Tate-Ramingham
    Member
    Posted 4 years ago #

    *BUMP*

    Anyone dealt with a similar problem?

  3. rtanttila
    Member
    Posted 4 years ago #

    I'm running version 2.9.2 and have also been experiencing the problem. I've tried nearly every option short of replacing files and folders to no avail.

  4. LFGabel
    Member
    Posted 4 years ago #

    There should be an easier way around this for non-techincal users.

    The way I got around it was to:

    - set temp folder permission to 777 (via ftp, like filezilla)
    - set wp-content and upload (and subfolders) permission to 777
    - upload media through dashboard
    - revert temp, wp-content, upload (and subfolders) back to 755.

    You need to do this for every upload session.

    Yeah, pain in the mother frickin' ass.

    Hey, WP developers, why not make this easier for everyone?

  5. pixelnate
    Member
    Posted 4 years ago #

    Hey, WP developers, why not make this easier for everyone?

    And I really don't like having any folders on my website set to 777, especially, when using php.

    The thing that gets me is that there is NO OFFICIAL RESPONSE to this very prevalent and highly annoying problem. And what's worse is that there is NO OFFICIAL SOLUTION. The only solution anybody can come up with is disabling any kind of security on your web directories.

    How can I pass off a website to a client and expect them to know how to change permissions on a directory just to upload photos?

  6. pixelnate
    Member
    Posted 4 years ago #

    Anybody solve this? Any pointers? Sorry to be annoying on this issue, but none of the fixes are working or appropriate. Setting permissions on any directory on the web to 777 is not a solution.

  7. pixelnate
    Member
    Posted 4 years ago #

    The support guys at my hosting company (Rails Playground) found this link. It worked perfectly. The best part about it is that my wp-content and uploads directories are both set to 755.

Topic Closed

This topic has been closed to new replies.

About this Topic