WordPress.org

Ready to get started?Download WordPress

Forums

Media Upload Error -- Missing a Temporary Folder (13 posts)

  1. aaronhester7
    Member
    Posted 1 year ago #

    I just migrated my site from Windows to Linux and am receiving this error from the media upload in WP.

    “home feature image example.jpg” has failed to upload due to an error
    Missing a temporary folder.

    Tried using browser upload and it still causes error in uploading.

  2. martha_camellia
    Contributor Day Volunteer
    Posted 1 year ago #

    This indicates that the temporary folder PHP uses for uploads is not available.

    Is this a hosted site? If so your host provider should be able to help you.

    If you have access to the php.ini file look for upload_tmp_dir and make sure the specified directory exists.

  3. aaronhester7
    Member
    Posted 1 year ago #

    I see a php5.ini file on the server. Here is what is in there.

    session.save_path=/home/content/64/10647864/html/tmp

  4. aaronhester7
    Member
    Posted 1 year ago #

    It is hosted at godaddy.

  5. martha_camellia
    Contributor Day Volunteer
    Posted 1 year ago #

    Who is your hosting provider?

  6. aaronhester7
    Member
    Posted 1 year ago #

    GoDaddy.

  7. martha_camellia
    Contributor Day Volunteer
    Posted 1 year ago #

    Contact GoDaddy and they should be able to get this resolved for you. Good luck!

  8. aaronhester7
    Member
    Posted 1 year ago #

    What to I tell them? I have explained the issue to them and they tell me that they don't support WordPress.

  9. martha_camellia
    Contributor Day Volunteer
    Posted 1 year ago #

    Argh, GoDaddy.

    This is not a WordPress issue, it is a PHP upload issue. You might get their help by explaining it that way.

    Also, do you have a folder under your home directory called /html/tmp? If not, create it.

    And if that doesn't work, do this:
    Open a plain text editor and create a file called phpinfo.php. Insert the following line:

    <? phpinfo(); ?>

    Save this file to the root of your Web site and then browse to yourdomain.com/phpinfo.php to test the settings. Find the line for upload_tmp_dir. What does it say, and does that directory exist?

  10. jahuerta26
    Member
    Posted 1 year ago #

    I'm having the same issue. What did godaddy end up doing/saying?

  11. satrntgr
    Member
    Posted 10 months ago #

    goDaddy told me they couldn't help. :p

  12. lesliebaird60
    Member
    Posted 5 months ago #

    Hi, godaddy is not great with support. I had to talk to a support person and get them to relay a message to a server support person who changed the max. upload on the back end. I had an upload setting of about 10mg. I needed it increased, but when I tried to add a php.ini file, and increase the upload size, it didn't work.

    This is probably a similar issue - they need to add a temp folder to the php.ini file in the back end. Keep talking on the phone with the support person and see if you can get someone who works on the server to do this for you - or see if you add a php.ini file somewhere in the file structure to do this. I think you might be successful if it is added in the root of the file structure?

    Just some suggestions

  13. Mohawk-Stampede
    Member
    Posted 1 month ago #

    My client is hosting with 1and1 and I'm having the same problem getting my WordPress Media Uploader to upload files. It's giving me the same error.

    I called 1and1 and they told me that it's just my client's package. He has Windows and it won't work because it's not Linux and there are restrictions everywhere. But would that be the problem? Or would the information in the upload_tmp_dir ,when I typed url.com/phpinfo.php to test, be of any service?

    I'm quite lost

Topic Closed

This topic has been closed to new replies.

About this Topic