WordPress.org

Ready to get started?Download WordPress

Forums

Media Tags
[resolved] Media-tags slug sanitizing not working on special characters (5 posts)

  1. mic79
    Member
    Posted 1 year ago #

    Awesome plugin, thanks for sharing! Just encountered the following problem: The Media-tag slug isn't being sanitized for special characters, for example
    Title: Louças Sanitárias
    Slug: louças-sanitárias

    Could this please be fixed in an update, and/or could someone please direct to where this could be manually altered in the plugin files?

    Thanks in advance!

    http://wordpress.org/extend/plugins/media-tags/

  2. pmenard
    Member
    Plugin Author

    Posted 1 year ago #

    @mic79,

    The Media-Tags plugin uses the same functions as any other taxonomy term sanitizing. So just like you would enter a Post tag. but will look into this later today.

  3. mic79
    Member
    Posted 1 year ago #

    @pmenard,

    Thanks for taking the time to look into this! I tested creating a new category in a post with special characters and the category slug got sanitized correctly.

    Defining a new Media-tag in the Edit Media window leads to a non-sanitized Media-tag slug.

  4. pmenard
    Member
    Plugin Author

    Posted 1 year ago #

    @mic79,

    Finally figured out the issue on the Bulk popup entry fields. The others seemed to work correctly.

    So here is the patched code. Would appreciate a second review before I officially release the change.

    https://dl.dropbox.com/u/2616987/projects/wp-plugins/media-tags/media-tags-3.1.1-Beta1.zip

  5. mic79
    Member
    Posted 1 year ago #

    Perfect! Tested and 100% ok!

    Many thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic