WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Media Stopped Appearing in Social Networks (10 posts)

  1. msbree
    Member
    Posted 9 months ago #

    About one week ago, I accidentally deleted my entire main media library via ftp (I was working in one of my subdomains, and thought I was deleting the media from the subdomain).

    Fortunately, I had saved the entire library to my desktop in a folder, keeping all the upload years/months in tact, so I quickly uploaded the entire library via ftp.

    The great news is that all image files have been restored to their exact location, and none of my posts/products have broken links. They all appear intact in the library, as they were prior to my stupid mistake.

    So all is good; however, the bad news is that none of these images are available to pinterest, Google+ or Facebook when I paste a new post's url to post in any of these social medias. Prior to this, I could paste the link of a new post and the featured image would automatically be available too, to go with the post.

    Now, when I attempt to pin new post (content), Pinterest gives me "Sorry we could not fetch the image" error. With Facebook and G+, the image just isn't available. This leads me to believe something is missing somewhere!

    Does anyone have any idea what might be wrong with the Media library and how I can fix it? Hope it's a simple fix!

    My site is http://bit.ly/10XrhjC

    Not to promote myself....believe me, at this point, this is the last thing I want or need, but go ahead and grab a post and try pinning it to Pinterest, G+ or even Facebook, and you'll see the image will not appear. You have my permission to delete it once you see what I'm talking about! *grin*

    I even completely uninstalled WP Super Cache and reinstalled a fresh copy of WordPress, but problem still exists.

    I hope someone can help me get to the bottom of this!
    thank you so much!!!

  2. msbree
    Member
    Posted 9 months ago #

    I just want to add that yesterday and today, I uploaded new images using the built in uploader in WordPress. These new images also are not being pulled in any of the social networks, yet they appear perfect on the site!

    Yesterday, I sent out a newsletter, linking directly to the images of the posts. When I received my e-mail copy of the newsletter, none of the images were showing.

    I got either a box with red x with message "The linked image cannot be displayed. The file may have been moved, renamed or deleted. Verify that the link points ot the correct file and location". When I double click this, the image opens perfectly on the web.

    Or, I get a small little box (image placeholder) with 3 tiny little graphics in it (little red square, green circle and blue triangle)!

    Please help! I'm at wits end trying to figure out what's wrong!
    thank you so much!!!

  3. msbree
    Member
    Posted 9 months ago #

    Please, can anyone help?

  4. msbree
    Member
    Posted 9 months ago #

    If anyone is reading this and has the same exact problem, check your htaccess file! This is where my problem was, and all is good again!

  5. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 9 months ago #

    What did you check within your .htaccess file?

  6. msbree
    Member
    Posted 9 months ago #

    Wish I could take credit, but it wasn't me. I ended up hiring an expert who was smart enough to go through this file very carefully until he discovered the issue! Sorry, but this is all I know!

    At least this information might help someone else experiencing the same problem, and rather than spending days looking in the wrong places like I did, having someone experienced with this file might be the first and last stop!

  7. Homika
    Member
    Posted 7 months ago #

    I wish you posted a bit more info on what was wrong in .htaccess. I have problem with pinterest fetching images form my website also, even thou I can clearly see them in the preview and any other social media can get to them with no problems...

  8. msbree
    Member
    Posted 7 months ago #

    Sorry @Homika, but as I wrote above, I hired an expert who figured out the problem. He was a Codeable contractor, and I do not have access to his contact information since I closed the job! I did not ask for specifics cause the .htaccess file is one file I do NOT touch!

    If I would have had more information, I would have posted it to help others, but I feel what I have posted, should at least rule out a lot of other stuff, which could cause time and money loss!

    So sorry....and hope you get your issue resolved soon!

  9. waffenss
    Member
    Posted 4 months ago #

    I am also having this issue but have made huge security mods to htaccess myself from growing DDos and botnet Brute Attacks

    Also have disable hot linking of my images in Cpanel without checking the (Allow direct requests (i.e., entering the URL of an image into a browser)BOX this may be the issue or not I did a major wp-options cleanup last night also.

    Why well site got locked down by host CPU state was 126% use lol, not sure if it is a looping DDos since they cant breach my SQL or admin, they pull the links of images and stuff on your site in loop overpowering server.

    most of my htaccess

    ErrorDocument 416 "Bad Request"
    RewriteCond %{HTTP_USER_AGENT} Alexabot/
    RewriteCond %{QUERY_STRING} share=
    RewriteRule .* - [R=416]
    
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} ^(.*)?wp-login\.php(.*)$ [OR]
    RewriteCond %{REQUEST_URI} ^(.*)?wp-admin$
    </IfModule>
    
    # Stop spam attack logins and comments
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	RewriteCond %{REQUEST_METHOD} POST
    	RewriteCond %{REQUEST_URI} .(wp-comments-post|wp-login)\.php*
    	RewriteCond %{HTTP_USER_AGENT} ^$
    </ifModule>
    
    <IfModule mod_expires.c>
      ExpiresActive on
    
    # Perhaps better to whitelist expires rules? Perhaps.
      ExpiresDefault                          "access plus 1 month"
    
    # cache.appcache needs re-requests in FF 3.6 (thx Remy ~Introducing HTML5)
      ExpiresByType text/cache-manifest       "access plus 0 seconds"
    
    # your document html
      ExpiresByType text/html                 "access plus 0 seconds"
    
    # data
      ExpiresByType text/xml                  "access plus 0 seconds"
      ExpiresByType application/xml           "access plus 0 seconds"
      ExpiresByType application/json          "access plus 0 seconds"
    
    # rss feed
      ExpiresByType application/rss+xml       "access plus 1 hour"
    
    # favicon (cannot be renamed)
      ExpiresByType image/x-icon              "access plus 1 week" 
    
    # media: images, video, audio
      ExpiresByType image/gif                 "access plus 1 month"
      ExpiresByType image/png                 "access plus 1 month"
      ExpiresByType image/jpg                 "access plus 1 month"
      ExpiresByType image/jpeg                "access plus 1 month"
      ExpiresByType video/ogg                 "access plus 1 month"
      ExpiresByType audio/ogg                 "access plus 1 month"
      ExpiresByType video/mp4                 "access plus 1 month"
      ExpiresByType video/webm                "access plus 1 month"
    
    # htc files  (css3pie)
      ExpiresByType text/x-component          "access plus 1 month"
    
    # webfonts
      ExpiresByType font/truetype             "access plus 1 month"
      ExpiresByType font/opentype             "access plus 1 month"
      ExpiresByType application/x-font-woff   "access plus 1 month"
      ExpiresByType image/svg+xml             "access plus 1 month"
      ExpiresByType application/vnd.ms-fontobject "access plus 1 month"
    
    # css and javascript
      ExpiresByType text/css                  "access plus 2 months"
      ExpiresByType application/javascript    "access plus 2 months"
      ExpiresByType text/javascript           "access plus 2 months"
    
    </IfModule>
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    RewriteCond %{HTTP_REFERER} !^http://(.*)?mysite\.com/.*$      [NC]
    RewriteCond %{HTTP_REFERER} !^http://(.*)?mysite\.com$      [NC]
    RewriteRule .*\.(jpg|jpeg|gif|png|bmp|mp4|mp3|pdf)$ mysite.com [R,NC]

    Just got word from my host it was the Alexa bot made my cpu use go up maybe you guys can improve your htaccess a little off some these entries though I will post back if I find that the hotlink protection is blocking the images.

  10. waffenss
    Member
    Posted 4 months ago #

    Yes if Hotlink protection is on in Cpanel please put a check for allow direct request by URL and the images will work on share hope this helps all

Reply

You must log in to post.

About this Topic

Tags

No tags yet.