WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Media Library uploading to wrong directory (6 posts)

  1. nckswt
    Member
    Posted 4 years ago #

    I'm not sure whether this started after installing wordpress 2.9 or after importing a local wordpress instance onto the one I'm publishing online, but the media library on my live instance is bugging out whereas my local one works perfectly.

    If I upload an image to my local instance, all proper thumbnails are created and the url of the main image is /wp-content/uploads/2009/12/DickEvans_PaulTellier.png.

    If I upload an image to my live instance, no thumbnails are created and /wp-content/uploads/2009/12/DickEvans_PaulTellier.png shows "file not found" (even though the media library shows that to be the file URL).

    The file is actually uploaded - I can tell because I can actually edit the file itself with wordpress's new image editor, I just can't see where it is on the server.

    Any ideas what's going on here?

  2. nckswt
    Member
    Posted 4 years ago #

    And yes, I've been through the sticky at the top of this forum - none of the images are greyscale (if that matters anymore) and, since they work on the local instance but not the live instance, although the two are (as far as I know) identical, I doubt it's an issue with the images themselves.

    Is there an easy way to find where the images are actually being uploaded to?

  3. Mark / t31os
    Moderator
    Posted 4 years ago #

    Look in your folders, and you'll likely find a random uploads folder floating around in the wrong place, compare this with the URL you've got set as the upload location, then update as appropriate, it's not uncommon for different configurations to require different upload paths..

  4. nckswt
    Member
    Posted 4 years ago #

    Thanks, but I really can't find the files anywhere. I'm using Coda as an FTP client, but there's no way to search the remote site – do I have to download my entire site to a remote directory and just use spotlight, or is there a better way to do this?

  5. nckswt
    Member
    Posted 4 years ago #

    Nevermind! I found the solution from this thread: http://wordpress.org/support/topic/308057?replies=17

    Comcorp wrote:

    I've found the problem.

    In Settings --> Miscellaneous

    Make sure that you have wp-content/uploads typed in the "Store uploads in this folder" field.

    It says it has "wp-content/uploads" by default, but this is not the case.

  6. Mark / t31os
    Moderator
    Posted 4 years ago #

    At least you can be happy it was something simple... ;)
    Happy it's all working for you.. :)

Topic Closed

This topic has been closed to new replies.

About this Topic