WordPress.org

Ready to get started?Download WordPress

Forums

Media Library - "Uploaded to" faults (4 posts)

  1. tedinoz
    Member
    Posted 3 months ago #

    "Uploaded to" = not updated if image is deleted from post

    If an image is inserted in a post, the Media Library displays the post name with a hyperlink to the post-edit page. However, if the image is later deleted from the post, the "updated to" field continues to display the details of the post.

    "Uploaded to" = shows only one post, even though an image may be inserted into multiple posts.

    An image can be inserted into multiple posts, however the "Updated to" field in the Media Library only ever shows the details for the first of those posts. The existence and identity of other posts in which the image has been inserted are never shown.

    Note: these faults are not new to Vn3.9; they have existed for some time.

  2. "Uploaded to" = not updated if image is deleted from post

    Yes, this is because the ajax doesn't reload. If you save the page and reopen the modal, it'll show as deleted.

    "Uploaded to" = shows only one post, even though an image may be inserted into multiple posts.

    This is a limitation of the system :/

  3. tedinoz
    Member
    Posted 3 months ago #

    Yes, this is because the ajax doesn't reload. If you save the page and reopen the modal, it'll show as deleted.

    I think you have missed my point. I am referring to the status in the Media Library - there is no modal. However... perhaps I expressed myself poorly. Try this step-by-step example:

    • Upload a new image to the Media Library ("Image A"). Note that the Media Library shows that the image is not "Uploaded to" to any post.
    • Open an existing post, click the "Add Media" button and insert "Image A". Save the post, view the post and note that image appears in the post.
    • Open the Media Library and note that "Image A" is shown as "Updated to" your post.
    • Open your post, click on the image, and click the "Delete Image" icon. Save the post, view the post and note that image doesn't appear in the post.
    • Logout of WordPress, clear your cache, and login again (this step is intended to demonstrate that this is not a session-based issue)
    • Open the Media Library and locate "Image A". The "Uploaded to" column should show the name of your post despite that you deleted the image from the post.
  4. tedinoz
    Member
    Posted 3 months ago #

    "Uploaded to" = shows only one post, even though an image may be inserted into multiple posts. This is a limitation of the system :/

    I guessed as much. Though I must say that it seems rather a substantial 'limitation'. Might I suggest two alternatives:

    1 = In the Media Library Screen, add a hyperlink, or button (or whatever) to open a modal window that shows all the posts in which the image has been "uploaded".
    OR
    2 = In the Image "Edit" screen, add a section to show all the uploaded posts.

Reply

You must log in to post.

About this Topic