WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Media Library not working properly after 3.8.1 update (5 posts)

  1. Annawari
    Member
    Posted 7 months ago #

    I can upload images to the media library without any problems. But when I try to insert images or a gallery into a post/project/page the images I recently uploaded to my library don't show up.

    I can upload them again while creating a gallery for a post for example, and everything shows up some what OK (square images are being stretched out) on my website but when I want to edit/or add to the gallery all the pictures are gone.

    I checked where my images are being uploaded and they're where all my other pictures are (public_html/wp-content/uploads/2014/01).
    I'm not entirely sure the 3.8.1 update is the source of my problem because I also tried a few new gallery plugins right around the time of the update. (WP Photo Album Plus and Photospace Gallery & I was already using NextGen)

    I deleted all gallery plugins and just kept the plugins that were working fine before the 3.8.1 update.

    Does anyone have an idea what's going on ?

  2. Annawari
    Member
    Posted 7 months ago #

    I figured out it was the WPML Multilingual CMS Plugin that was causing the problem. (disabled all plugins and reactivated them one by one).

    Then I found the solution on a WPML forum:

    1. Go to your Media Library and locate an image file. Click on "Edit" to go to the "Edit Media" screen of this file.

    2. Scroll all the way to the bottom of the page and look for the "Make 'Media' translatable" checkbox.

    3. It should be disabled. If it is already disabled, enable it first the save. Next disable it and save again. This will cause WPML to re-save its settings.

    4. Visit the "WPML settings" ("WPML -> Support -> Troubleshooting") again and search for [custom_posts_sync_option] you'll see that [attachment] is on 0 as it should be*.

    * It should be either on 0 or not there at all!

  3. sona2014
    Member
    Posted 6 months ago #

    I have the same problem. I tried inactivating all plugins but it didn't make any difference.

    I cannot even click on text icon.

  4. gleenk
    Member
    Posted 4 months ago #

    Wow thank you so much Annawari! I got the same problem with WPML and solved it!

  5. Cablewaves
    Member
    Posted 2 months ago #

    Thank you very much! Lifesaver.

Reply

You must log in to post.

About this Topic