WordPress.org

Ready to get started?Download WordPress

Forums

Media Library doesn't work since upgrade to 3.5 (14 posts)

  1. Sandsand
    Member
    Posted 1 year ago #

    Hello,
    I know there is numerous post with this error in the new media library, with no answer yet.

    Since I've upgraded to wordpress 3.5, the media library does not work. It shows no images, and when I try to upload, I have this message :
    An error occurred in the upload. Please try again later.

    But the image is loaded, I saw it in the media tab, and in ftp I saw the 3 images small, medium and original. The problem is there is no images shown in the media library.

    Tried to desactivate all plugins, clear the cache, use two others browsers, use the twenty twelve theme : always the same problem.
    My wp-config has already the line
    "define('CONCATENATE_SCRIPTS', false );"
    I tried to delete the htaccess, too. Same problem.

    I made an exact mirror of my blog in a local server, with my custom theme and plugins, and here all is ok, the media manager works perfectly. The Php version is the same (5.3.6). Don't know exactly where is the problem. I don't use the mod pagespeed.

    Thank you for any clue of this problem. Perhap's it javascript or jquery with a conflict in the server configuration ?

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Try replacing:

    define('CONCATENATE_SCRIPTS', false );

    with:

    define('SCRIPT_DEBUG', true);

    And try asking your hosts whether they are using mod_pagespeed on your server.

  3. Sandsand
    Member
    Posted 1 year ago #

    Thank you for your reply.

    Replacing
    define('CONCATENATE_SCRIPTS', false );
    With
    define('SCRIPT_DEBUG', true);
    Don't change anything.

    And there is no informations about mod_pagespeed in my phpinfo, so I assume my host does not use it.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    I'd actually ask your hosts about mod_pagespeed.

  5. Sandsand
    Member
    Posted 1 year ago #

    My host said to me mod_pagespeed is not activate on my server.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

  7. Sandsand
    Member
    Posted 1 year ago #

    Forget to tell that I always do manual upgrade. I use wordpress since 2005, and I've keep this habit.

    Try to diagnose javascrip errors, the only one I found is this :

    [18:08:36,852] L'utilisation de l'attribut « specified » d'un attribut est obsolète. Cela renvoie toujours « true ». @ http://blog/wp-includes/js/jquery/jquery.js?ver=1.8.3:2

    Line 2.

    In english : Use of attributes' specified attribute is deprecated. It always returns true.

  8. Ethane
    Member
    Posted 1 year ago #

    You already got an answer on this one? That you can share in this topic. I was following it :).

  9. Sandsand
    Member
    Posted 1 year ago #

    No more answer, problem is still here with 3.5.1. I've installed a plugin, "faster image insert" for continuing to blog.

  10. Ethane
    Member
    Posted 1 year ago #

    Yea, but you use faster image insert on the back end?

  11. Sandsand
    Member
    Posted 1 year ago #

    Yes

  12. Ethane
    Member
    Posted 1 year ago #

    oke, im trying to figure it out how i get faster image on the front end.. any idea?

  13. dasmonk
    Member
    Posted 1 year ago #

    I am having the same problem. Please let me know if you find a fix! We're using the same theme as well.

    we also get this error message on top of every page since the upgrade. I've tried all of the fixes listed in the forums, to no avail.

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'wp_maybe_load_embeds' not found or invalid function name in D:\Hosting\9569105\html\wp-includes\plugin.php on line 406

  14. Sandsand
    Member
    Posted 10 months ago #

    My problem is solved.
    It was an hosting issue, a php file called "prepend.php".
    This default code :

    <?
    ?>

    don't work in php 5.3 and cause the bug with the media library.
    Replacing the first line with

    <?php

    solve my problem.

Topic Closed

This topic has been closed to new replies.

About this Topic