WordPress.org

Ready to get started?Download WordPress

Forums

MAYOR PROBLEM! HELP! (16 posts)

  1. kcire
    Member
    Posted 4 years ago #

    A website that has I just launched is suddenly totally messed up?!?

    I have all files and folders in a folder called 'art'...

    So for a while now I am working on http://www.thewebsiteathand.nl/art/
    and visitors visiting the main-index page see a message: website almost ready! (or something).

    Today I was busy fixing it so now without the word 'art' it would be available for visitors. So when visiting http://www.thewebsiteathand.nl visitors would see the website.

    Unfortunatly I did something wrong in the 'settings' mainpage from the admin section...

    I removed the word 'art' somewhere and now everything is lost....

    Somebody here maybe knows what I mean?

    The person I made it for allready sended her 'I have a new website' email to all her friends and so...I am in stress...

  2. ousep
    Member
    Posted 4 years ago #

    This is what you did, but probably didn't go through all the steps...
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    You'll need to do step 7 onwards, and delete the index.html file with the 'website almost ready' message.

  3. kcire
    Member
    Posted 4 years ago #

    That's exactly what I was trying to do....

    I'll try what you say!!! thanks be back in a minute!

  4. kcire
    Member
    Posted 4 years ago #

    I have tried what you said but after visiting the

    http://www.thewebsiteathand.nl/art/wp-login.php

    and login in, I get the followingmessage:

    Not Found
    The requested URL /wp-login.php was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2 Server at http://www.estherleijen.nl Port 80
    -------------

    In the 'settings' section you have two lines of text that state a URL, one being for example:
    http://www.thewebsiteathand.nl/blog/

    and the one following:

    http://www.thewebsiteathand.nl

    ...here I removed the word 'art' from one of them...

    You know what I mean by this?

  5. ousep
    Member
    Posted 4 years ago #

    Yes.. that seems about right.
    Just to check, do you have an index.php under /art/, or is it under public_html?

  6. kcire
    Member
    Posted 4 years ago #

    The index is in both?

  7. kcire
    Member
    Posted 4 years ago #

    From the steps on:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    ...at Step 4 I have removed the word 'art'...and then heaven fell down on me...

    It's frustrating...everything was ready....

    What to do?

    How can I put this little word 'art' back there?

  8. ousep
    Member
    Posted 4 years ago #

    You'd have to move the index.php from the /art folder to the public_html folder. If you changed your permalink settings, shift .htaccess as well.

    If there's already an index.php in public_html, rename it to index_old.php. After the site is working, you can check to see what the file contains.

  9. kcire
    Member
    Posted 4 years ago #

    I have done what you said.

    the index.php from the 'art' folder was moved to the public_html folder...

    But what to do with the .htaccess?

  10. ousep
    Member
    Posted 4 years ago #

    1. Shift htaccess to public_html
    2. Go to http://www.thewebsite.nl/art/wp-admin/ and login
    3. Go to Settings > permalinks, and click on save changes.

  11. kcire
    Member
    Posted 4 years ago #

    Hey Ousep,

    When I follow these last three steps...

    I can fill out the username and password, but when clicking on 'Log in' the page ends up in a 'page not found' message...

  12. ousep
    Member
    Posted 4 years ago #

    The only thing I can think of is that, perhaps, you deleted the word art in the wrong place.

    If that's the case, you'd probably need to access your phpmyadmin from your hosting control panel.
    Browse to the wordpress database, and the wp_options table. Your siteurl should be http://www.sitename.nl/art

    Making that change should bring you back. I'm only guessing that this is the issue.

  13. kcire
    Member
    Posted 4 years ago #

    Mmhh...I will try to look if this is the case...Uno momento por favor...

  14. kcire
    Member
    Posted 4 years ago #

    Hey Ousep...

    I got into the MyAdmin bit of WordPress and added 'art' behind the siteURL and everything seems oke now!

    See: http://www.estherleijen.nl/

    Thanks a million for your assistance!

    It's been emotional....

  15. ousep
    Member
    Posted 4 years ago #

    Nice to see it all in place... Glad I could help...

  16. kcire
    Member
    Posted 4 years ago #

    What would I've done without you...

    See ya,

Topic Closed

This topic has been closed to new replies.

About this Topic