WordPress.org

Ready to get started?Download WordPress

Forums

Nike+
[resolved] Maybe it's me but.... (10 posts)

  1. Stridesnshapes
    Member
    Posted 1 year ago #

    I've been waiting for an update that will work with the Nike+ website, I'm not sure that this is the one. I upload and activate, but can't find an 'edit my profile' page. Do I have to create one? So far, plugin is a dud. Hope to be able to resolve this.

    http://wordpress.org/extend/plugins/nikeplus/

  2. James Laws
    The WP Ninjas
    Plugin Author

    Posted 1 year ago #

    If you have a WordPress site to install this plugin then you have user profile at YOUR_DOMAIN.com/wp-admin/profile.php.

    At the bottom of that page is place to enter your Nike+ Credentials.

  3. Stridesnshapes
    Member
    Posted 1 year ago #

    Okay, I found that page I just enter email(username) and password? Still doesn't work! I get no verified users in widget + no data.

  4. James Laws
    The WP Ninjas
    Plugin Author

    Posted 1 year ago #

    Have you visited the Nike+ settings page and save your settings? It checks for stats on a schedule and when you install the plugin the schedule begins. You can manually check for updates by visiting that page and clicking the button.

    As long as your credentials are correct it will fetch data although the widget should show you as a runner in the dropdown if you've entered your data appropriately.

    Other then that without having access to your admin it's really hard for me to troubleshoot.

  5. Stridesnshapes
    Member
    Posted 1 year ago #

    okay, you are saying that I need to enter my data in that profile.php page, in what format? If that is indeed the page I need to edit I have done so, without success.

  6. James Laws
    The WP Ninjas
    Plugin Author

    Posted 1 year ago #

    Nike+ uses your email as your username and then of course your password. That's all that's needed to connect to Nike+. I'm using the plugin myself on my personal site so I know it works.

    Are you sure your server has the proper specs? I state on the plugin description that...

    IMPORTANT
    Currently NIke+ plugin requires PHP 5 with cURL and JSON. While these are common it's not beyond belief that not all web hosts have these exact specs set-up in your server.

  7. Stridesnshapes
    Member
    Posted 1 year ago #

    Yes I checked.

    Do I edit profile.php and if so where?
    This is what it looks like:

    <?php
    /**
     * User Profile Administration Screen.
     *
     * @package WordPress
     * @subpackage Administration
     */
    
    /**
     * This is a profile page.
     *
     * @since 2.5.0
     * @var bool
     */
    define('IS_PROFILE_PAGE', true);
    
    /** Load User Editing Page */
    require_once('./user-edit.php');

    where and how do I enter my data?

  8. James Laws
    The WP Ninjas
    Plugin Author

    Posted 1 year ago #

    You don't actually edit php files. In your admin there have been new options to enter your credentials into the form fields of your user profile.

    You should never need to edit WordPress core files or plugin files to get a plugin to work. If it's not working there is something else going on with either your Nike+ credentials, you data coming from Nike+, or some conflict in another plugin or your theme.

    It is also entirely possible there is something within the Nike+ plugin but as I've not had anyone else with this issue I have no way of knowing what that might be.

  9. Stridesnshapes
    Member
    Posted 1 year ago #

    I got it, thanks.

  10. Nav-sat
    Member
    Posted 7 months ago #

    I've the same problem. I did everythink what you wrote in instruction, but plugin doesn't show my stats.
    http://img27.imageshack.us/img27/6061/8ufm.png

    I checked my password etc.

    Could you say me how can I connect my stats with site (no widget) like on your website (http://jameslaws.com/running/).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.