WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Maximum upload file size: 8MB. (10 posts)

  1. randomblink
    Member
    Posted 2 years ago #

    I'm losing my mind...

    I've changed, re-created, added new php.ini with a 100M file upload size... I've modified my .htaccess... I've adjusted the Multisite Settings to allow 1,000,000 KB file uploads... nothing changes that damn upload text on my sites from 8MB?!

    Can someone PLEASE help?! This doesn't make ANY SENSE...

  2. randomblink
    Member
    Posted 2 years ago #

    Ok...
    I just went into my NETWORK settings and changed the max upload to BLANK.

    When I went to my site, it said my Maximum File Upload was 0KB...

    I went back and changed the NETWORK settings to 1000 KB.
    It showed 1MB on my site...

    I went back and changed the NETWORK settings to 100000KB.
    It showed 8MB on my site... again!

    How do I get past that 8MB?!?!

  3. randomblink
    Member
    Posted 2 years ago #

    Copied the 100M upload php.ini file to wp-admin... resolved.

    ridiculous...

    Maybe we could have that upload page have a link on the upload size number so that we could click on it and get to a settings page that shows WHERE that size is being controlled from?

  4. randomblink
    Member
    Posted 2 years ago #

    Resolved.

    Move a php.ini file to your wp-admin folder and it will accept the values.

  5. Jamil Jonna
    Member
    Posted 2 years ago #

    i can't believe you finally figured this out. this has been a problem for me for at least a year. what a pain.

  6. castortray
    Member
    Posted 1 year ago #

    it doeasn't work for me :(

    does anyone have othe solution ?

  7. spyze
    Member
    Posted 1 year ago #

    Try this :
    Increase the setting values in php.ini (e.g. upload_max_filesize = 64M ; and post_max_size = 64M ;)

    seemed to work for me...

  8. sylviashannon
    Member
    Posted 1 year ago #

    Spyze, thanks for posting the solution. I had the same issue, and it worked for me.

  9. sinanonline
    Member
    Posted 1 year ago #

    I created a soft link in the wp-admin directory to my php.ini file. That solved my problem. (The uploader page reads '16M' right now.) WordPress v3.5

    cd wp-admin
    ln -s /etc/php5/apache2/php.ini php.ini

    Note that the location of the actual php.ini will vary with the Linux distro.

  10. Umair ul haq Usmani
    Member
    Posted 1 year ago #

    This is the solution..... hope you will enjoy

    You can change that setting by making a simple text file and putting it into the wp-admin folder.

    So to make this file all you have to do is open a simple text program like textedit on Mac or notepad on Windows and type these two lines of code.

    upload_max_filesize = 64M;
    post_max_size = 32M;

    You can put in any value you want I just chose 64 and 32 because they seemed like good numbers. So now you just save the file and name it php.ini the program will ask you if you want to use the ini extension, click use ini and save. Now all that is left to do is upload the file to your server and place it in the "wp-admin" folder, anywhere in the root section of the folder is fine.

    Now login to your WordPress control panel and try and upload something large. It shouldn't give you any problems and upload whatever you want!

Topic Closed

This topic has been closed to new replies.

About this Topic