WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Facebook: Advanced Social Optimization
[resolved] Maximum Number of Videos (0) (20 posts)

  1. Seehank
    Member
    Posted 1 year ago #

    Hello I love your plugin, however I am not able to set the Maximum Number of Video to 0. Eventhough I go to the settings, find thid value, set it to 0, after Save All it will jump back.

    Is there a way to do it manually? (some cfg file or something) There seems to be a bug in the backend administration som I am looking for a simple solution...

    Filip

    http://wordpress.org/extend/plugins/nextgen-facebook/

  2. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Seems you found a little bug there. ;-)

    Download and install the current DEV version from http://downloads.wordpress.org/plugin/nextgen-facebook.zip, and let me know if that fixes things for you.

    Thanks,

    js.

  3. Seehank
    Member
    Posted 1 year ago #

    Perfect, its working :) Thanx for a lightning fast response!

  4. Seehank
    Member
    Posted 1 year ago #

    Eeem one more thing. It stays switched, thats cool. However when I post a link to Facebook, a link to a page that has some pictures and text and a YT video on it, FB will always preload the video on the wall. Meaning people are immediatelly able to watch the video from the post and I dont want them to watch it on FB, I want them to go to my site read look and than maby watch the video.

    Is this even possible? I thought it is Open Graph working too good :-) But it might be FB. Any Idea?

  5. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Yeah, I'm not too fond of that behavior either. NGFB can only put information in the Open Graph headers -- Facebook decides what to do with it. In the case of videos, it embeds the video instead of linking it to the source webpage.

    There are two possible "solutions" (I'll have to out this in the FAQ):

    - Turn off videos completely by setting "Maximum Number of Videos" to "0".

    - Un-check the og:video og:video:width and og:video:height tags. This will leave the video preview image, but leave out the URL that Facebook uses to embed the video.

    js.

  6. Seehank
    Member
    Posted 1 year ago #

    If this is what you mean, I figured that out some time ago: http://awesomescreenshot.com/0941a4fr4f however, doesnt help :-/

  7. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    I've noticed that the Facebook scraper can be "greedy" at times -- gets more information from the webpage than what's in the Open Graph headers. My guess is that if it detects a problem with the Open Graph headers, it goes into "second gear" and scrapes the webpage itself.

    Do you have a URL to an example problem page?

    js.

  8. Seehank
    Member
    Posted 1 year ago #

    Well this is the URL I am fighting with. Its a blog of a friend of mine: http://thejsfworld.com/we-all-beautifull/

    According to what you sayed I reactivated the meta tags with a 0 on videos so FB does not think there is anything broken... However that did not help either :-/ I believe it is Facebook...

    F

  9. Seehank
    Member
    Posted 1 year ago #

    JUST SOLVED IT!

    This plugin I am using for YT videos must have overcome yours: http://www.embedplus.com/ and pushed the video up on FB.

    Now I simply added the video to YT using html embed code and it all works out :)

    Hope this will help to someone sometime :)

  10. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Cool.

    BTW, for some reason, NGFB is showing duplicate images in the Open Graph header:

    <!-- og:image:1 --><meta property="og:image" content="http://thejsfworld.com/wp-content/uploads/2013/05/385314_10152459786150164_1683174433_n-550x550.jpg" />
    <!-- og:image:1 --><meta property="og:image:height" content="550" />
    <!-- og:image:1 --><meta property="og:image:width" content="550" />
    <!-- og:image:2 --><meta property="og:image" content="http://thejsfworld.com/wp-content/uploads/2013/05/385314_10152459786150164_1683174433_n-550x550.jpg" />
    <!-- og:image:2 --><meta property="og:image:height" content="550" />
    <!-- og:image:2 --><meta property="og:image:width" content="550" />
    <!-- og:image:3 --><meta property="og:image" content="http://thejsfworld.com/wp-content/uploads/2013/05/385314_10152459786150164_1683174433_n1-550x550.jpg" />
    <!-- og:image:3 --><meta property="og:image:height" content="550" />
    <!-- og:image:3 --><meta property="og:image:width" content="550" />
    <!-- og:image:4 --><meta property="og:image" content="http://thejsfworld.com/wp-content/uploads/2013/05/431285_10152436506485164_1671360675_n1-550x550.jpg" />
    <!-- og:image:4 --><meta property="og:image:height" content="550" />
    <!-- og:image:4 --><meta property="og:image:width" content="550" />
    <!-- og:image:5 --><meta property="og:image" content="http://thejsfworld.com/wp-content/uploads/2013/05/fotka-550x550.jpg" />
    <!-- og:image:5 --><meta property="og:image:height" content="550" />
    <!-- og:image:5 --><meta property="og:image:width" content="550" />

    Any chance you could turn on NGFB's debug mode (bottom of settings page) so I could determine why? ;-)

    Thanks,

    js.

  11. Seehank
    Member
    Posted 1 year ago #

    You got it :)

    Add Hidden Debug Info is ON

    Thanks,

    F

  12. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks - I saved the info to have a look at it later (second coffee). ;-)

    You can turn off debug mode.

    Thanks,

    js.

  13. Seehank
    Member
    Posted 1 year ago #

    No problem, loved to help!

  14. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    I made lots of small changes here and there to improve duplicate checks between the various class methods. You can download the latest DEV version from http://downloads.wordpress.org/plugin/nextgen-facebook.zip.

    That'll get rid of that duplicate image in the OG header. ;-)

    js.

  15. Seehank
    Member
    Posted 1 year ago #

    Hey... now this is great! Look at this url pls: http://thejsfworld.com/second-week-of-my-espria-challenge/ from same blog, same things and yet FB ignores EVERYTHING :-D

    This is really strange... It is the new version you posted. Other posts work but this one...

    Any ideas?

  16. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    There's no NGFB info on that page at all. Might be worth turning on debug mode.

    js.

  17. Seehank
    Member
    Posted 1 year ago #

    Debug is ON. This is strange :-/ I did not do anything different and shazam! it stopped working :D

  18. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Looks good now. You can turn off debug mode now I guess. ;-)

    js.

  19. Seehank
    Member
    Posted 1 year ago #

    Hmm, well I did turned it off :) But, well waht now :D Any updated version or something?

  20. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like it's working fine now.

    js.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic