WordPress.org

Ready to get started?Download WordPress

Forums

max_allowed_packet error (8 posts)

  1. besonen
    Member
    Posted 5 years ago #

    starting yesterday every post to a wordpress 2.3.1 installation is generating a mysql error message that includes the string:

    "Got a packet bigger than 'max_allowed_packet' bytes"

    in #wordpress i was told to increase the mysql max_allowed_packet value. this wordpress installation is on a shared host so i cannot make this change (although i will be making this request to the isp today).

    what are some potential reasons this problem might suddenly arise? and might there be another solution?

    fwiw, this error is generated only when a post is published and even with the error message the post is published correctly. can i assume that i'm *not* dealing with any database corruption and that this error message is simply a warning of sorts?

  2. besonen
    Member
    Posted 5 years ago #

    i spoke to technical support at my web host and was told that they would *not* change the max_allowed_packet mysql value

    the max_allowed_packet size is currently set to 1MB. does worpress typically need a larger value than 1MB?

    also, i'd love to get to the bottom of this so if you have any thoughts on why this might be happening please speak up.

    thanks,
    david

  3. MichaelH
    Member
    Posted 5 years ago #

    What if you create a post with just one sentence--same problem?

    Have you tried optimizing your MySQL database tables? Please backup your database before doing that.

    Who is your host?

    In doing a little searching of 'max_allowed_packet' the recommendation is to increase that limit, but hard to see why a post is doing that.

    Of course, another question might be, what happens if you upgrade to a newer WordPress version?

  4. syncbox
    Member
    Posted 5 years ago #

    I've never experienced this error in all the years I've used WordPress and I use it a lot, for a lot of different types of sites.

    I would look at another host. Separate of that, perhaps you are using too many plugins and or other enhancements that are causing issues?

    Like the OP said, optimizing your db would be a good start.

    Also, as a test, try setting your site to a default theme, disabling your plugins and doing a test post. Does the problem go away? If yes, then turn on your plugins one by one and do more test posts, one after each plugin you activate. Still OK? Change back to your original theme.

    Error back? It's your theme... or something in it.

    That would be my approach and of course, once you nail down the issue, delete the test posts.

    HTH
    Casey

  5. besonen
    Member
    Posted 5 years ago #

    1 hour ago, MichaelH wrote:

    > What if you create a post with just one sentence--same problem?

    yes

    > Have you tried optimizing your MySQL database tables?

    no

    > Who is your host?

    pair.com

    > In doing a little searching of 'max_allowed_packet'
    > the recommendation is to increase that limit, but
    > hard to see why a post is doing that.

    that's about what i came up with too.

    > Of course, another question might be, what happens
    > if you upgrade to a newer WordPress version?

    other folks with the same problem reported that upgrading wordpress did nothing to solve the problem. of course i might have a different experience.

    thank you very much for replying.

  6. besonen
    Member
    Posted 5 years ago #

    1 hour ago, syncbox wrote:

    > I would look at another host.

    that's something i'm considering as a final solution--assuming that the problem actually is with pair.com (they are a great host).

    > perhaps you are using too many plugins and or other
    > enhancements that are causing issues?

    possible but unlikely (i only use a few plugins).

    > Like the OP said, optimizing your db would be a good start.

    previously i said i haven't optimized the database. but i just remembered that the database is set to be auto-optimized by the host once a week.

    i'm not familiar with the nuances of database optimization. are there different types of optimizations that can be performed?

    > try setting your site to a default theme

    the default theme is what is being used.

    > disabling your plugins and doing a test post

    i've disabled some and the problem still manifests. i'll disable the remainder and post another test post.

    thank you for your help.

  7. besonen
    Member
    Posted 5 years ago #

    someone over in #mysql said that the "Got a packet bigger than 'max_allowed_packet' bytes" error message means that the mysql client sent too much data.

    so it would seem that for some reason wordpress has started sending more data than usual. and interestingly, it would seem that wordpress might be sending both the post because it posts successfully and then sending something too large (which is what triggers the error message).

    does wordpress have a mysql client built-in? and if so, is there a way from within wordpress to monitor the mysql client transactions?

  8. MichaelH
    Member
    Posted 5 years ago #

    that for some reason wordpress has started sending more data than usual

    STARTED is the operative word there. What's changed if your WordPress version installation has remained the same? A plugin, a new theme.

    Just a shot, but maybe installing the dump_queries program describe by Ryan on this trac topic might tell you something
    http://trac.wordpress.org/ticket/8229?replyto=10#comment

Topic Closed

This topic has been closed to new replies.

About this Topic