WordPress.org

Ready to get started?Download WordPress

Forums

Max. Upload File SIze Ignored by WP Media Library (4 posts)

  1. ffwebdesigner
    Member
    Posted 1 year ago #

    I got a very strange Problem on a WordPress MU site. I edited php.ini settings to accept max filesize 200M. worked all fine on plugin FileManager. But in media library, i get a 1MB upload limit, no matter how high i adjust the values in php.ini.

    phpinfo tells me: 200MB - but WP with all plugins disabled giving me 1MB in media library. Tried the same settings in functions.php and .htacces. No change. I don't have any special entries in wp-config.php.

    My Php.ini looks like:

    [PHP]
      engine = On
      short_open_tag = On
      date.timezone = "Europe/Berlin"
      precision = 14
      y2k_compliance = Off
      output_buffering = Off
      output_handler =
      unserialize_callback_func =
      zlib.output_compression =
      implicit_flush = Off
      allow_call_time_pass_reference = On
      safe_mode = Off
      safe_mode_gid =
      safe_mode_include_dir =
      safe_mode_exec_dir =
      safe_mode_allowed_env_vars = "PHP_"
      safe_mode_protected_env_vars = "LD_LIBRARY_PATH"
      disable_functions =
      highlight.string = "#CC0000"
      highlight.comment = "#FF9900"
      highlight.keyword = "#006600"
      highlight.bg = "#FFFFFF"
      highlight.default = "#0000CC"
      highlight.html = "#000000"
      expose_php = On
      max_execution_time = 90
      memory_limit = 256M
      error_reporting = 32759
      display_startup_errors =
      track_errors = Off
      variables_order = "EGPCS"
      register_argc_argv = On
      post_max_size = 200M
      gpc_order = "GPC"
      magic_quotes_runtime = Off
      magic_quotes_sybase = Off
      default_mimetype = "text/html"
      doc_root =
      user_dir =
      enable_dl = On
      file_uploads = 1
      allow_url_include = 1
      arg_separator.output = "&"
      arg_separator.input = "&"
      max_input_vars = 2000
    
    [mail function]
      SMTP = "localhost"
      sendmail_from = "me@localhost.com"
    
    [SQL]
      sql.safe_mode = Off
    
    [ODBC]
      odbc.allow_persistent = 1
      odbc.check_persistent = 1
      odbc.max_persistent = -1
      odbc.max_links = -1
      odbc.defaultlrl = 4096
      odbc.defaultbinmode = 1
    
    [MySQL]
      mysql.allow_persistent = Off
      mysql.max_persistent = -1
      mysql.max_links = -1
      mysql.default_port =
      mysql.default_socket =
      mysql.default_host =
      mysql.default_user =
      mysql.default_password = 
    
    [PostgresSQL]
      pgsql.allow_persistent = On
      pgsql.auto_reset_persistent =
      pgsql.max_persistent = -1
      pgsql.max_links = -1
    
    [bcmath]
      bcmath.scale = 0
    
    [browscap]
      browscap = 
    
    [Session]
      session.serialize_handler = "php"
      session.gc_probability = 1
      session.referer_check =
      session.entropy_length = 0
      session.entropy_file =
      session.cache_limiter = "nocache"
      session.cache_expire = 180
      session.use_trans_sid = 1
      url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
    
    [Assertion]
      assert.active = On
      assert.warning = On
      assert.bail = Off
      assert.callback =
      assert.quiet_eval = Off
    
    [suhosin]
      suhosin.post.max_vars = 5000
      suhosin.request.max_vars = 5000
  2. greekdish
    Member
    Posted 11 months ago #

    I have the same problem, WordPress 3.6, Ubuntu Linux...I changed my server to 64MB and phpinfo also shows it working....but WP Media Manager still refuses to go over 8MB....once I added in

    php_value upload_max_filesize 64M
    php_value post_max_size 64M
    php_value max_execution_time 300
    php_value max_input_time 300

    to the htaccess file and.....

    define('WP_MEMORY_LIMIT', '64M');

    to the wp-config file....its still only 14MB. This is ridiculous.

  3. esmi
    Forum Moderator
    Posted 11 months ago #

    This is a server issue - not a WordPress one.

    And greekdish, please post your own topic.

  4. ffwebdesigner
    Member
    Posted 11 months ago #

    hi esmi,

    agreed in the first place and greekdishs problem. checked everything: php ini, server setup, htaccess, @php ini settings in wp files. my hoster domainfactory agreed: everything is setup right and should result in a 200m upload max file size not only in file manager plugin, but also in media library. but it doesn't. 200m is possible with my hoster, file manager acts as expected.

Topic Closed

This topic has been closed to new replies.

About this Topic